Hosting - Inmotion Hosting

Hello, how are you, good afternoon, I have a problem with the DNS redirection, I made a purchase of a hosting in inmotion hosting, I connected it to my domain provider and everything worked fine, but now I pointed the dns to Cloudflare and it broke, I have tried to add a NS type record in Cloudflare but it still does not redirect the hosting, has someone experienced something similar.

Welcome to the Cloudflare Community. :logodrop:

Can you describe what that means? Do you encounter any error messages that you can share?

You probably should not do that. It is far more likely to cause unexpected problems than whatever you are hoping it will do.

You should consult your InMotion documentation for your site’s IP address and create an A record in your Cloudflare DNS. Don’t forget to delete the NS records you added, too.

Thank you very much for answering, I detail what I have done:

1.- Buy a domain from provider A
2.- Buy a hosting in inmotionsHosting
3.- Inmotion Hosting gives me an NS record that I must add to my domain provider (A), if I add it there, the web works.
4.- I met Cloudflare, they also give NS records.
5.- Unregister inmotionHosting and add Cloudflare.
6.- In Cloudflare add the NS records, in the DNS section wait 2 days but it doesn’t work, the message “DNS_PROBE_FINISHED_NXDOMAIN” appears on the web.
7.- Add an A record with the inmotionHosting ip but the message “DNS_PROBE_FINISHED_NXDOMAIN” still appears.

I don’t know if I’m doing something wrong

As described in my previous reply, you need to remove the InMotion NS records from Cloudflare. You cannot use both InMotion nameservers and Cloudflare. You need to create your DNS records, such as A, MX, etc., in your Cloudflare DNS app.

Hello, if I did that, I deleted the Cloudflare ns records but it still doesn’t do the redirection :(, I created a type A record with the inmotionhosting IP in Cloudflare but it still doesn’t work

Can you share your domain?

Mi domain is :

codesfirst . com

Thanks for sharing that. I see ERR_TOO_MANY_REDIRECTS when I try to visit the site. Have you looked at the Community #tutorial covering that error? One of the most common solutions is to make sure that your Cloudflare SSL mode is set to Full (Strict).

1 Like

It worked, I didn’t know that I had to configure the ssl in Cloudflare, I really appreciate it, thank you very much for your help :).

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.