Hosting email with IMAP access separate from website

I have put configuration setting for EMAIL on DNS, setting MX, TXT. The email is not functioning


properly.

I am not able to use POP3, IMAP on GMAIL app android, email is not delivered over round cube webmail, i am not able to access specialist.com:2096 for webmail.

I only want to use cpanel for email hosting and use another server for website hosting. Please help

Any DNS entries used for mail services (such as mail, smtp, imap`, etc) must be set to “DNS only” and not “Proxied”. I only see proxied records so if this…

…means you have records on your control panel, those won’t work as Cloudflare is now providing DNS for your domain.

If you can give the domain name, it is easier to check.

Port 2096 is available through the Cloudflare proxy, but only for HTTPS…

You can host mail and web separately, but you need records for them in your Cloudflare DNS.

Usually you would have records for the domain and subdomains for web proxied (@, www, cpanel, etc) and specific subdomains for email (usually mail) which must be “DNS only” and an MX record pointing to the same for incoming mail and to access your mailbox.

I guess you’d need something like a “DNS only” CNAME for mail to s690.lon1.mysecurecloudhost.com based on your current settings.
https://cf.sjr.org.uk/tools/check?ed861871542a4e23ba80bc2c610d662a#dns-mail

1 Like

I have created a new CNAME point into the server. The cpanel link still bring error. Android phone login using gmail pop3 and imap said username or password is incorect

That works ok…

dig +short mail.kingsmithspecialist.com
s690.lon1.mysecurecloudhost.com.
77.95.113.15

Check at the mail server end. Your Cloudflare settings seem ok.

1 Like

What is mail server end, please

It means that you should work with your email hosting provider to confirm that you have everything configured correctly in their system.

I use https not http

When you encounter a 522 error, it means that your server is not responding to requests from Cloudflare. This guide has more information that you can use to work with your host to determine why it is not responding.

This webmail is not even proxied. Should i send my entire set up again after modifications?

That screenshot was of your main cPanel login, not your webmail. Your webmail is loading for me.

You did not load the same URL that I did. The address bar in my screenshot hides it, but my request was made to port 2096. Yours was made to port 443 (HTTPS default). I see the same 404 page when I omit :2096 from the end of the address.

Try specifiying the port like you described earlier in this topic.

Thanks. It went through. I really appreciate. This one is SOLVED. The next thing now is the pop3 and imap. THANKS

1 Like

Hello

The who problem is solved. Thanks to you all

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.