Hostgator Free SSL Cert. with Cloudflare Causing Redirect Issue

Any help would be greatly appreciated.

I need some assistance on what may be the A record and DNS in Cloudflare for my WordPress site that needs to change. I had everything set up correctly since the time I started several years ago. I never changed the A record for my site.

Today, Hostgator set up my free SSL Certificate. During this process, they told me to turn off DNS in Cloudflare so I clicked the orange cloud for my site and the gray cloud appear.

Hostgator then told me to turn on the DNS (A record) for my site and so I did.

However, an issue occurred. My WordPress site got some kind of redirect URL issue. Also, I could no longer log into my WordPress Admin area with DNS turned on. The http:// does redirect to https:// without using a plugin. With DNS off, my site appears online and I can also log into the Admin area.

Hostgator told me to contact Cloudflare for help concerning my A Record.

How can I fix the redirect issue with DNS on? What are the steps?

Is there something I need to do with my A record?

Well…weren’t they helpful.

If your WordPress site is now full-on SSL with a local cert, and SSL at Cloudflare, WordPress needs the following set to https. And Cloudflare’s SSL set to Full (Strict).
https://wordpress.org/support/article/changing-the-site-url/

I don’t know about full-on SSL. Hostgator set up the free SSL using Let’s Encrypt. Are saying go to SSL/TLS in Cloudflare and set SSL to Full (Strict)?

DNS is just an address book, so browsers know where your server is. If your DNS records for example.com and www.example.com point to the correct IP address, you can proceed to SSL:

In order to use Cloudflare and have HTTPS, you need end-to-end SSL. You already have your end taken care of with the Let’s Encrypt certificate. To take care of your users’ end, you need the last hop from Cloudflare to have SSL turned on…either Full, or Full (Strict). Since your server has the appropriate Let’s Encrypt certificate, you should use Full (Strict).

cfssl_strict

The Redirect issue comes up when all parts of the chain are not in agreement with using HTTP or HTTPS. Something along the way thinks it should be HTTP, and is redirecting it that way.

  • It could be the server not letting you use SSL. Not likely, since your host just installed it.
  • It could be WordPress, thinking your site uses HTTP, from before you had SSL. WP Dashboard’s General Settings has a section for this that is not easily overridden, but wp-config can fix it.
    30%20PM
  • It could be Cloudflare’s SSL/TLS settings, which need to be Full or Full (Strict) to use SSL.
  • Or it could be a Cloudflare Page Rule that overrides the Cloudflare Crypto setting.

My opinion is that when you talk about DNS on or off is you’re talking about using the Cloudflare proxy or not. Cloudflare OFF (:grey:), your end of the chain is all happy with SSL and it works. Cloudflare ON (:orange:), and Cloudflare still thinks your server is set to HTTP, so tries to redirect to HTTP, and your server tries to redirect back to HTTPS.

1 Like

OK… Just read your last message. I think I have it now. I’ll follow your instructions. Thanks

1 Like

sdayman… Thank so much!. Your last explanation with steps really summed it all up for me. I just learned something new. Lucky for me all it took was Crypto >> SSL >> Full (strict) with DNS on.

Thanks a million and I’m going to save your instructions.

1 Like

This topic was automatically closed after 31 days. New replies are no longer allowed.