Hostgator + CloudFlare SSL Error


#1

I have my hosting through HostGator at the current moment. I have a Flexible SSL Cert with CF and it seems that every few minutes I get a 521 error. I contacted HostGator and apparently they have an issue where their server thinks it is getting attacked because my requests are going through CF? Anyone have a solution to this? It just recently started. I haven’t had this problem since about 24 hours ago.


#2

#3

Hostgator just sent me this reply: “Thank you for contacting Hostgator. I am sorry to hear that you are having issues with your DNS. Unfortunately, it looks like the issue is related to your cloudflare dns not hitting the server. I would recommend first turning off cloudflare to test and then try reconnecting the domains. It should be fairly simple to do and if you have to you can use your dns zone in cpanel to add the information in manually. I hope this information was helpful. Please let us know if you have anymore questions. We look forward to hearing from you”


#4

It seems that the Flexible SSL cert is the cause of the issue. When I disabled that and used Cloudflare for DNS only, the site works perfectly.


#5

Try turning off SSL, but still use Cloudflare set to :orange: for your domain.


#6

Setting the cloud to orange and turning off SSL produces the same 521 error


#7

Lets start off with which domain you are talking about :wink:


#8

lasd1013.org


#9

Currently works, but shows a regular directory listing.


#10

Try https://forums.usairwaysvirtual.org/


#11

So which one is it?


#12

I just got a 521.

I just think Hostgator doesn’t feel like looking through logs to track this down and it’s easier to blame Cloudflare. Those 521 instructions @domjh posted are spot on.


#13

It has errors every few seconds if you try to refresh the page. When I tried installing forum software, it randomly came up with the 521 error. HostGator claimed it was because CloudFlare uses a range of IP addresses instead of the real visitor’s IP and that they couldn’t help me by whitelisting the range of IP addresses.


#14

Which domain are you talking about?

usairwaysvirtual.org or lasd1013.org


#15

They claimed because I am on a Shared server that they can’t whitelist CloudFlare’s IP range.


#16

Both have the same error. If you look at sdayman’s post you will see what I am getting.


#17

http://sitemeer.com/#lasd1013.org/ shows partial availability. Right now it seems Cloudflare PoP dependent. That could be either a Cloudflare issue or - probably more likely - an issue of your host.

Thats going to be fun to debug :unamused:


#18

Possibly rate limiting as suggested in @domjh’s link.


#19

Assuming your server’s IP address is x.x.x.8 it does seem as if it is reachable, on both HTTP and HTTPS, however neither domain has a proper certificate associated, so you couldnt use “Full strict” to begin with and would need to use regular “Full” until you have sorted that out.
That being said, the forum link does not return anything either but a 404.

At this point my assumption would be there is something that makes your host reject certain connections from Cloudflare. Why that is only they can say. But again, thats speculation.


closed #20

This topic was automatically closed after 30 days. New replies are no longer allowed.