Homepage not being served by search engines

Hello- having a strange issue here. The home page of my site is not being served by Google, Bing, or DuckDuckGo.

I haven’t changed anything about it. Google and Bing webmaster tools say the page can be crawled, and is indexed.

Site audit does not indicate any canonical or redirect loop issues. .htaccess looks fine and has not been changed.

Even the web traffic appears normal.

When I checked in Cloudflare, I don’t notice any issues here either. And I haven’t changed any of my settings in recent history.

But wondering if there is something specific I should check… or any suggestion about why this is happening.

May I ask you to share your domain name?

Did you recently started using Cloudflare and this happened or?

Maybe some SPAM comments or URLs somewhere in the content?

A change from HTTP to HTTPS? Re-indexing? Robots “noindex, nofollow”?

May I ask you to check if there are any blocked requests at the Cloudflare Dashboard → Firewall → Events?

If using WordPress and Yoast SEO, maybe some plugin update?

Hi- thanks for the reply.

The domain name is: www.orchidholisticsearch.com.

Nothing really has changed. I made some minor updates to one of the pages- there are only 7 of them, and there really isn’t any user interaction except for a form.

It is not built on a site platform, and there are no plugins.

The firewall shows several JS Challenge blocks from users outside the U.S. Which is normal because I set it up like that.

There are also a handful of fake googlebot blocks- I checked the homepage with the URL inspector google tools and it says it is fine. Bing tools also says all good.

The subpages can be found in the search engines. But even if I search for something that would normally turn us up on page one- even with our company name- it does not appear.

1 Like

I checked and I do see your naked domain + www homepage both URLs are crawled and indexed at Google.hr (at least):

https://www.orchidholisticsearch.com/robots.txt file is loading fine, but why I do not see any sitemap line stated inside it?

  • https://www.orchidholisticsearch.com/sitemap.xml

The question is, how could any of the search engines know what to crawl and index for your domain (or not) despite of a way to submit the sitemap manually to them?

Google Mobile Test and Google Rich Snippets Testing Tool is ok:

Furthermore, I do not see any HTML <meta> for robots in the source code view for your website.

Neither I do se a canonical <link>.

I am afraid this is not an Cloudflare issue here.
Also if you could confirm you do not see any of the challenged/blocked Firewall Events from Google ASN → but the above Google Tests Tool passed fine and it’s good, so I doubt it’s that.

Kindly, modify your robots.txt file and re-send your sitemap to Google Search Console again.
Add the missing HTML <meta> tag to each webpage.
Add the missing canonical <link> tag to each webpage.
After submitting the sitemap to Google Search Console, manually ping Google to re-crawl and re-index your sitemap by visiting below url:

  • https://www.google.com/ping?sitemap=https://www.orchidholisticsearch.com/sitemap.xml

That’s for Google, not sure if Bing has got the same approach, but once you add your domain to any Webmaster tools, you have to have robots.txt configured properly and submit your sitemap.xml.

Nevertheless, using online Sitemap Generator Tool, I still got only 7 URLs to crawl:

Maybe you might want to point your domain name or rather HTTPS property from Google Search Console to the correct Language / Region as it’s related to your website visitors, to make sure the results show up in Google.com better and rather than in Google.hr for example.

Hi- Thanks for your detailed reply.

That is strange if it is not being shown in the U.S. only… I set the international setting to U.S. however never had that done before, so not sure why that would have become a problem.

I have canonical on each page! That is also very strange if it is not being shown on your end. Makes me think some weird CDN thing?

I added the sitemap line to robots.txt, but I’m not sure about the because I would just have them all set to “all” which makes it unnecessary… I think.

Google is not blocked by the firewall, as far as I can see.

Thank you for providing feedback information about this issue.

Correct way, yes.

O-oh, I checked again, now I see it.

I take back what I said, seems like I mistyped in the search field when trying to find it - it’s right at the top of the source code view!

Agree, good way to re-think before adding it, but unsure how could it affect Googlebot crawler, etc.

Great! :+1:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.