Homepage error with CF but correct with direct hosting

Hi… I am getting huge benefits from CF there is a problem.
My homepage always looks like ugly due to mixed content error but there is no mixed content on the site…

I have contacted my hosting provider but what i get from them is -

Hello,

I have checked and it seems that the issue is caused by one of the settings of the CDN you are using.

I have loaded the home page of the site directly from our server and this is how the site looks on our server:

https://nimb.ws/agxWFL

You should check the settings of your Cloudflare CDN closely and remove any settings that could interfere with the sites overall look.

For example you can deactivate the Rocket Loader if the page uses a lot of JavaScript since the loader is known to cause issues with some sites.

so but rocket loader is not enabled on my subdomain.

here is the url of error page onlinetest.sbfied.com

!

and here is the screenshot. plz help me to solve this problem

Probably your issue:

https://onlinetest.sbfied.com/wp-content/uploads/siteground-optimizer-assets/siteground-optimizer-combined-styles-93442bb530f6bfebd3a88292fff14f88.min.css

creates a 404 (not found). I guess that caused the issue since it’s a style sheet.I am absolutely clueless at the moment but to rule out any perfomance setting, you could try a Page Rule

https://onlinetest.sbfied.com/*
Disable Performance

Clear your cache afterwards and try again.

I have tried what you said…and it works… but problem is that by this way i am afraid of no pages will be cached and there will not be any use of CF cache…

When I used page rule and purge the cache …every thing is fine but when i off the page rule … same thing happen… any better solution so that CF cache will be helpful to minimize the resources usage

OK try another

Take the full URL for that CSS, add a Page Rule:
Auto minify :
:ballot_box_with_check: HTML
:x: CSS
:ballot_box_with_check: JS

This topic was automatically closed after 30 days. New replies are no longer allowed.