Home Web Server A Record Not Resolving


#1

I have an Nginx web server running on a Raspberry Pi 2 at home, intended to both serve as a MEAN stack server as well as a proxy server for two other servers (LAMP and NETCORE) I want to set up as well.

I have internal static IPs within my home network and have properly forwarded the Nginx’s IP at port 80 through my router. Going to http://[my.ip.is.here] successfully gets me to my server.

However, when I set up a name record with Cloudflare to map my server to a subdomain (Name = my-subdomain, Value = [my.ip.is.here]), it doesn’t work. Namely, it loads and loads and never resolves. CURL says I’m getting an error 409, though I don’t understand why or how to fix it.

I’ve contacted my registrar (Hover) and my ISP (Midco) and both confirm that the issue is not on their ends. It should be noted that I do NOT have a static IP for my router (my ISP does not provide them for home users), but that shouldn’t be the source of this issue as my router’s IP hasn’t changed in the past couple days anyway (I set up the A name record about two days ago).

Any advice would be greatly appreciated. All tutorials and examples I’ve found imply that I’ve already covered every required step to get this working. What gives?


#2

You have Cloudflare set to:
a. Always use https
b. SSL Full (crypto tab)

However the origin server is not listening on port 443 which results (for me) in a 502 error. Try setting a page rule for my-subdomain.your.domain to use Flexible SSL and see if that resolves the issue.


#3

That not only fixed it, it fixed it instantly. Thank you so much! I would have never thought to do that.


#4

This topic was automatically closed after 14 days. New replies are no longer allowed.