Home page does not update unless Cloudflare is paused (caching problem)

wordpress
cache
dash-crypto
#1

Recently, I’ve been having an issue where, when a new post is made on my website, a caching problem occurs and the changes are not visible on the home page. If I go into an incognito browser or another browser with no caching, this problem still occurs and the updates that should be there are not (I only see them as an administrator via Wordpress).

When I put Cloudflare in Development Mode, that does not fix the problem. However if I pause Cloudflare completely, then the problem is fixed (for that one instance).

The recent change brought to my site is a host move to SiteGround and the use of their own caching system called “SuperCacher.” A Let’s Encrypt SSL certificate was also recently added.

My website uses the following caching sources:

  • WP Rocket plugin (compatible with Cloudflare)
  • Cloudflare caching
  • Ezoic caching (CDN for ad optimization, compatible with Cloudflare)
  • SiteGround’s SuperCacher (currently on static caching and not dynamic, compatible with Cloudflare and WP Rocket)

Because the problem gets fixed when I pause Cloudflare, I assume the problem somehow lies with Cloudflare? I’d appreciate any insight.

#2

Post a screenshot of all your page rules. Also, what is the URL of that article?

#3

Sure, here are my current page rules.

The URL of the website is personacentral.com. It’s not relevant to a specific article, but when any new article gets published, the page will not be updated unless I pause Cloudflare. The newest one is “Persona 5 Royal 5-Minute Update Video Released on New Story, Student and Phantom Thief Life: ‘Morgana’s Report #1’”, but that should appear properly since I’ve gone through the process of pausing Cloudflare and reactivating it already.

#4

You are caching everything under uploads.

#5

Would that prevent posts from being updated on the main page? I thought the page rule was only relevant to media uploads for images and such, not for posts that are supposed to be published to the main page.

Also, I should mention that that page rule has been put in place for a very long time; more than a couple of years now. This problem is recent.

#6

I dont know where your articles are located and you didnt address my question either. So assuming your articles are under uploads that page rule would cache everything. Otherwise it shouldnt unless there is another page rule.

#7

Here is the example of a URL address structure for an article: https://personacentral.com/persona-5-royal-morgana-report-1/

As mentioned in an edit above, those two page rules have been put in place for a very long time, and they never gave me any issues.

#8

The document itself does not appear to be cached, there are no caching headers on Cloudflare’s side. You said when you pause Cloudflare it does not seem to occur, so can you definitely rule it could be any caching on your server or maybe the client?

#9

Well, I’m not sure what’s happening, that’s why I’m trying to determine it. All I know is:

  1. The home page looks like X before I publish a post.
  2. I publish a new post, and the home page should look like Y with the updated post included in the latest articles.
  3. Outside of the administrator view, the home page still looks like the original X, which should not happen.
  4. I purge the WP Rocket cache, the Ezoic cache, the Cloudflare cache, and the SiteGround cache, and nothing happens. The home page still looks like X. Even when Cloudflare is in development mode.
  5. I deactivate all sources of caching (WP Rocket, Ezoic, SiteGround). The page still looks like X.
  6. I pause Cloudflare and suddenly, the home page is updated to look like Y. I reenable Cloudflare, and the home page still looks like Y.
#10

Considering the Cloudflare cache has been purge we could rule out Cloudflare in this case. Development disables caching altogether.

#11

Then why does the home page only return to normal when I pause Cloudflare and with nothing else?

#12

That should not be the case. However it is difficult to say anything without being able to reproduce it. All I can say at this point is the document itself does not return any Cloudflare related caching headers. You might want to open a support ticket.

#13

It’s as I described in my original post; nothing else works except for pausing Cloudflare. I’m not sure I’m able to open a support ticket; I have a free version of Cloudflare and only pay for Dedicated SSL. That’s why I asked here, for anyone who could provide insight on the issue.

#14

Free accounts are still supported, answers take longer.

#15

Okay, so where do I go to submit a support request? I click on “My Activities and Requests”, click on “Submit a request,” and I’m brought to a page which states “Cloudflare system status,” “Ask the Community,” and “Get additional help” pointing to the Help Center.

#16

This will sound really obvious, and I don’t mean to sound condescending at all, but just checking that you are allowing the caches time to clear. i.e. 30sec from when you purge the Cloudflare cache and it isn’t just a coincidence that you click purge, check it, doesn’t work, pause Cloudflare and it works when you re-enable it as the cache has then had time to clear.

This ^

#17

Also, pausing and unpausing can take some time because of the propagation.

1 Like
#18

Yes, of course. After purging, I’ve waited about 5 minutes before pausing Cloudflare both times this has occurred, and no change. But both times, things changed immediately when I paused Cloudflare.

And thank you, I thought that would just redirect me to the Help Center.

1 Like
#19

Potentially related is diagnostics which returned the following:
“The origin web server for personacentral.com is responding slowly to initial requests for uncached HTML content. To remove this performance bottleneck, look at your server’s ability to return HTML faster and/or implement HTML caching in Cloudflare. You may benefit from caching static HTML and anonymous page views. Learn how to do this in: WordPress, Drupal and Magento.”

#20

Can you list the plugins you are using in WordPress? I get the feeling your troubles are related.