Home Assistant with Cloudfare Add-on - 404 error

I’m trying to setup Cloudflared addon in Home Assistant and when opening URL from the log, an error arise: “404 | We can’t find the page you’re looking for.” According to wiki, I should verify domain name in addon but it is correct.

Log from addon:

  • Add-on: Cloudflared*
  • Use a Cloudflare Tunnel to remotely connect to Home Assistant without opening any ports*
  • Add-on version: 4.2.2*
  • You are running the latest version of this add-on.*
  • System: Home Assistant OS 10.4 (amd64 / qemux86-64)*
  • Home Assistant Core: 2023.8.1*
  • Home Assistant Supervisor: 2023.07.1*
  • Please, share the above information when looking for help*
  • or support in, e.g., GitHub, forums or the Discord chat.*
    [22:10:49] INFO: Checking add-on config…
    [22:10:50] INFO: Checking for existing certificate…
    [22:10:50] NOTICE: No certificate found
    [22:10:50] INFO: Creating new certificate…
    *[22:10:50] NOTICE: *
    [22:10:50] NOTICE: Please follow the Cloudflare Auth-Steps:
    *[22:10:50] NOTICE: *
    Please open the following URL and log in with your Cloudflare account:
    Leave cloudflared running to download the cert automatically.
    2023-08-07T20:11:44Z INF Waiting for login…
    2023-08-07T20:12:37Z INF Waiting for login…
    2023-08-07T20:13:30Z INF Waiting for login…
1 Like

Same issue here… always getting a 404 error when I try to access https://dash.cloudflare.com/argotunnel

1 Like

Hi @dn38416, sorry for the inconvenience here. Could you create a Support Ticket, feel free to reference myself in it, so we can proceed investigating this further with the team internally?

I’m getting same error using client on Windows c:\Temp>cloudflared login and opening URL.

This is the same case as Argo tunnel 'login' - All attempts to login return 404, impossible to create any tunnels - #10 by jnperamo which has been raised by the nice MVP’s here now, I would watch that for updates.

1 Like

Still getting the 404 error when I go to https://dash.cloudflare.com/argotunnel

But I seem to have got mine working by adding a tunnel manually via https://one.dash.cloudflare.com/ and going to Access > Tunnels, creating a tunnel and grabbing the token from there and then entering it in the configuration options in the cloudflared addon.

I then restarted the addon and to my surprise, it worked.


Thanks, it works now!


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.