High TTFB time

My site: https://www.logoglo.com

Im going crazy trying to make my website speedy, BEFORE caching (as the most important speed test in my opinion, is that of a 1st time visitor.)

If I disable caching, the TTFB time is very high (on average around 2 secs)

I have optimized as best I can using wp-rocket, my site is only around 1.12mg in size, it should not be taking this amount of time to load for a 1st time visitor.

I know there is an article on why TTFB time shouldnt matter, but come on, it does, if its taking 1-3 secs before a visitor sees anything, that visitor is going to go away.

Any help is appreciated.

Is this Cloudflare related or do you have the same issue going directly to the site?

This is the third thread you created on the same topic.

Wordpress is slow. Especially on shared hosting. If you cache the html at Cloudflare you can get TTFB down to 20ms or less.

Sorry, im all over the place, I know, my apologies…how do I go about caching the html? and that will only make it faster on a second view of the page right? the cached version, not a 1st time visit?

Im confused at how much Cloudflare influences the speed, If I disable caching, will things like rocket loader still work? If I disable caching, will my site put load on the origin server?

Well, it might not be a good solution for you since you have a logged in state at your site. But if you want to fiddle, read on.

Create a page rule for your home page url. Set the cache level to cache everything. Load the page twice in a brower with cache disabled. The second load should be super fast.

My issue is the 1st time load, 2nd time load with the settings I have is blisteringly fast. If I disable everything that caches, its 6secs, (even with caching on for a 1st time visitor its clocking between 4-6 secs) so, is that a cloudlfare thing or a godaddy thing? without caching, where is the site loading from, Cloudflare servers or godaddy servers?

Also, yeah, adding page rule makes the wordpress bar visible to everyone, anyway to stop that happening?

One note, try turning off RocketLoader and clear your cache. There have been a couple reports that the current version of it slows down WordPress in certain cases. I’m not familiar enough with the details to know if it would apply to you, but it’s a harmless thing to try.

Thanks, yeah, I did a bunch of tests, turning features off and on both here and in wp-rocket, what I have right now is the fastest I have.

So this is with caching, and wp-rocket, everything, bells and whistles, and its still got a wait time of 2.5 secs…frustrating:

Firstly, don’t go by speed testing tools’ timers. They are always slow, giving you unneeded anxiety. You can follow their speed rules though.

Secondly, the first time load after clearing CF’s cache doesn’t count. It needs at least one page load for CF to prime it’s cache. This has nothing to do with your browser’s cache, or any user’s cache. Keep your browser cache off while developing.

You are probably best off using a wp-caching plugin like Comet Cache. It’s user-state-aware and will speed up TTFB by 10x. Then at Cloudflare, do not cache html. Give that a shot and let us know.

Thanks, yeah, I get the 1st time load on speed test sites, but isnt this what matters to 1st time visitors to the site? like I said, when its caching, its really fast, what I worry about is that 1st uncached visitors load time.

What I wanna know is, without caching, is it still loading via Cloudflare servers? or is it loading on godaddy servers? or a bit of both?

I see all the files load pretty quick after the first byte, so it must be a server issue? but I wanna know is it cloudlfare of godaddy.

If its godady, then I think I will switch to kinsta, but I need ot know if thats the issue, or something in Cloudflare, or something in my settings…

Thanks for your help.

I’m closing this topic, as this is also being covered in your other thread. Please don’t open up multiple threads on the same subject.