High Cache Misses

On a daily basis, I get a high cache miss vs hit ratio.

The percent cached for the last 30 days is currently at 9%. I do not use Edge Cache as that breaks my website but I do have cache everything in the page rule. Most of my visitors are from the same few countries. While my website is loading quick, I’m just wondering if there’s anything that I could do to improve caching. Any suggestion?

Even within a country, there are usually many different data centers, each with their own servers, all with independent caches, which is why it takes a fair amount of traffic to generate more HITs.

If that’s a 30-day graph, that’s not enough traffic to load the cache and keep it active enough to retain files.

The graph is for the last 24 hours. How much traffic would a website require to generate regular HITs?

1 Like

This is interesting. Can you show us your page rules?

And then, try use an extension called Dr.Flare to investigate which resources are not cached while you are visiting your page.

There’s nothing much in my page rule. Basically it is just one rule https://www.example.com/* with Cache Everything.

I do have Dr.FLARE plugin install and the thing is, I get a HIT on all the css and images with polish working as well.

Maybe you can add another option - Edge Cache TTL and set it 1 day or more.

Tried that before but Edge Cache will break member login so I removed it

You can create another page rule to bypass cache for login pages and other dynamic contents.

Wish it was that simple. If only the Bypass Cache on Cookie is available for pro users

If your site runs on WordPress, you can use APO ($5/month on free plans, free on paid plans).

If it’s not WordPress, you could use Workers, but it would require some custom coding.

1 Like

I’m not using WordPress but would be interested to use Workers if you could point me in the right direction?



1 Like

@weischin we are working on open sourcing some of the building blocks to make implementation easier for such use cases.

1 Like