Hey Fellas

Recently I set up my ssl certificate with Cloudflare. From Cloudflare side everything set up correctly and I also set up page rules from http to https.

Thing is that my page doesnt load the ssl certificate. https://bohcha.com

Can anybody tell me what would be the problem?

Thanks a lot!

That would be a mixed content issue.

Mixed content errors mean that your website is being loaded over HTTPS but some of the resources are being loaded over HTTP. To fix this you will need to edit your source code and change all resources to load over a relative path, or directly over HTTPS.

For example, if you load your images with a full URL:

<img src="http://example.com/image.jpg" />

You would want to change this to:

<img src="//example.com/image.jpg" />

By removing the http:, the browser will use whichever protocol the visitor is already using. An alternative option would be to enable the Automatic HTTPS Rewrites feature that can potentially fix these errors for you automatically. Do be aware that resources loaded by JavaScript or CSS will not be automatically rewritten and mixed content warnings will still appear.

See this Community Tip for further details

PS: I would not use a Page Rule for the HTTP to HTTPS redirect, there is a toggle “Always Use HTTP” in the SSL/TLS page.


Running Cloudflare diagnostic tells me that the domain is not routing traffic through Cloudflare. Check that the name servers are updated on your hosting provider. https://www.cloudflare.com/diagnostic-center/?url=bohcha.com

It was working before, something has been changed since my posting…

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.