Heroku: www subdomain returns “no such app”


#1

I recently set up my website https://socialmediabreakup.com. This domain works fine, but when I try http://www.socialmediabreakup.com, I get a heroku “no such app” error. I’ve already set up a page rule: www.socialmediabreakup/* < 301 - premanent redirect < https socialmediabreakupcom/$1

Why is the www not working? Do I need to add another redirect?


#2

You’re pointing to a service which also uses Cloudflare and so their settings are likely taking effect. Try changing the value for your www record to 192.0.2.1 (basically not that provider) and see if the page rule takes effect.


#3

Hi,

Thank you for your prompt response. I’m trying to understand what your advise, basically make a new rule in addition to the existing one adding:
www.socialmediabreakup.com/* < 301 redirection < 192.0.2.1?


#4

No sorry, I realize now I was unclear.

Change the DNS record for www to point to that IP address and make sure the record itself is :orange: in the DNS control panel. If you do that I believe the rule will ‘magically’ start working.


#5

Hi again,

I already have DNS record that points to clickfunnels.

I’ve attached a screenshot of my DNS profile.


#6

Yes as I mentioned previously, you are pointing to a service which also uses Cloudflare so their settings are taking effect, not your page rule. Changing the destination to an address where their settings don’t take precedence is how you get your page rule to work.


#7

I’m unable to change WWW record settings since it is being managed by target.clickfunnels.com


#8

Delete the existing record create an A record to the address I mentioned previously.


#9

Ok, done. How long does it for changes to take effect?


#10

~= 5 seconds. It’s working now in my test.


#11

Thank you, man!! WOW, good one. So even though I removed CNAME < WWW of target.clickfunnels.com I shouldn’t experience any issues with clickfunnels integration right?


#12

Correct, you are redirecting www to your root domain so it should work just fine. :slight_smile:


#13

Once again, thank you very much. You’ve made my week!!!

Have a lovely day!


#14

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.