Heroku Bad Request Server 400 Error

Hi there, I’ve been using Cloudflare successfully with my github pages account for a while now.
But now I want to move over to my Heroku web app and I appear to have entered all the details correctly but I keep getting Bad Request Server 400 Error when I try to access my site. This has been going on for over 2 hours now.

My GoDaddy registrar details have not been changed:
dane.ns.cloudflare.com
nola.ns.cloudflare.com

My setup is exactly the same as a previous question asked here:

    > CNAME   MYDOMAIN.COM   [heroku alias url1]    Automatic     [orangecloud]
    > CNAME   WWW                      [heroku alias url2]    Automatic     [orangecloud]

Also like that previously question I also got the ‘nothing here yet’ Heroku page for [heroku Alias url1] and [heroku alias url2] .

I have added the custom domain at the Heroku side to get these alias urls.

What other config might I be missing here?

Is there any way I can debug this situation to see what is going on? (The 400 error doesn’t give me any more information).

Again, as was the case with the other similar question, if I access the heroku alias urls it give me the “nothing here” page

And if you switch it to :grey: and wait 5 minutes to update, does it work with HTTPS?

Hey sdayman thanks for your reply! I already have the orange cloud (proxy) switched on. I turned off all https with SSL (in SSL tab) to eliminate that as a possibility as I read there can be a delay with that. Should I switch SSL back on to full?

Should I switch it back to “full” in this screen?

Sorry I stupidly forgot to add ‘palestinetechjobs.com’ to my list of allowed hosts in my Django app. I have now pushed up that code but when using the curl command: curl -I palestinetechjobs.com I’m now getting 301 response instead! Please help!

HTTP/1.1 301 Moved Permanently
Date: Thu, 02 Apr 2020 14:07:51 GMT
Content-Type: text/html; charset=utf-8
Connection: keep-alive
Set-Cookie: __cfduid=dd52a7e6e7327f3a96ebf5f8201cbe8f21585836470; expires=Sat, 02-May-20 14:07:50 GMT; path=/; domain=.palestinetechjobs.com; HttpOnly; SameSite=Lax
Location: https://palestinetechjobs.com/
X-Content-Type-Options: nosniff
Via: 1.1 vegur
CF-Cache-Status: DYNAMIC
Server: cloudflare
CF-RAY: 57db1e567d84ce2f-LHR

ps: I’ve switched over to flexible SSL.

It sounds like the answer to this was “no”.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.