Help with S3 aliased behind Nginx


#1

Hi,

I have a Wordpress site that’s hosting my podcast, with the media files being served up by S3. However, in order to get listening stats I needed to make sure that my listens were coming from my domain. What I did was set up an HTTP proxy for my S3 bucket in Nginx. Unfortunately it doesn’t appear that any of that content is actually being cached. Here’s an example link:

This goes through a few re-directs for stats tracking purposes, but it eventually hits my site. I can see some S3 headers, but nothing indicating a cache hit or miss from Cloudflare. Am I missing a header or accidentally stripping something in my proxy?


#2

.mp3 isn’t a filetype that’s cached by default.

You could create a Page Rule to match https://purplesquadsec.com/*.mp3 and add a setting for Cache Everything with an Edge Cache TTL that’s pretty high.


#3

This topic was automatically closed after 14 days. New replies are no longer allowed.