Help with redirecting my domain to bluehost

dns

#1

Hi, please bear with me, I’m not too tech savvy.

I purchased the domain www.carolafuertes.com from godaddy. I was hosting it with bluehost, and decided to use Kajabi for the subdomain “content.carolafuertes.com”. Kajabi requires me to use Cloudfare to add my custom domain, so I had to input the cloudfare servers in godaddy. in the DNS secion of cloudafare I was able to associate the subdomain with kajabi, but now apparently the whole domain is with Cloudfare and not with bluehost. How can I redirect everything but that particular subdomain to bluehost again? thanks in advance!


#2

Looks like the root domain carolafuertes.com works. You should go to the DNS tab, copy the IP address for your root DNS zone (carolafuertes.com) and create a new A record, “name” being www with the same IP address.


#3

Thank you, that is what the support person with bluehost told me to do. And they gave me the IP address. So I did exactly what you said, plus i deleted the previous A record, and created this new one, but I get this error at the bottom of the page:

DNS Validation Error (Code: 1004): This DNS record cannot be proxied - click the cloud icon to turn it gray to proceed (Code: 9041)


#4

BTW, i turned the cloud next to the old A record gray first and since it wasn’t working, i tried deleting it altogether.


#5

If possible, could you post the IP?


#6

Sure, it’s 162.241.244.138


#7

Make sure it’s entered without any following or leading spaces, I was able to add it fine in the dashboard while :orange:.


#8

that is weird… it worked now… was it something you did?? thanks anyway!

so do i have to wait now until it propagates or something?


#9

It does take some time to propagate, but looks like your www record works.

You should however add back the DNS record for your root domain @, pointing to the same IP, so that it will also load correctly.


#10

I’m sorry but I don’t understand what you’re saying. Could you please tell me exactly what I need to to, where to click what to select, etc? Thank you so much for your help


#11

Currently only your www subdomain works. For the “root” to work, http://carolafuertes.com, you should create another A record, with the name set to “@”, and the same IP address as the one you posted above.


#12

Thank you! I did that, but still when i type www.carolafuertes.com or carolafuertes.com i get to a temp domain with bluehost (http://box5200.temp.domains/~carolafu/). I know that one way to solve this is to put bluehost’s servers’ name on godaddy… but that would require that I eliminate cloudfare’s from there… is there another way to do it? What i acually want is to be able to create prettylinks from that domain.


#13

I’m getting a nice looking WordPress Coming Soon page at both the www and the root domain.

The content subdomain is also properly loading from Kajabi.

At this point, I’m going to say “don’t change any of your DNS settings.” And start building your sites.


#14

Hey, thank you so much for reaching out to me!

As I mentioned on the forum, I want to create a pretty link like www.carolafuertes.com/cutelink, and when I go inside wordpress I get a http://box5200.temp.domains/~carolafu/cutelink instead… not cute at all! Do you know what I can do to fix this?

Thank you so much for your help!

//Carola


#15

I suspect your Wordpress installation doesn’t have the proper URL set. Hopefully you can modify wp-config.php in your Wordpress directory to add:

define( 'WP_HOME', 'http://www.carolafuertes.com' );
define( 'WP_SITEURL', 'http://www.carolafuertes.com' );

https://codex.wordpress.org/Changing%20The%20Site%20URL

That way, Wordpress will internally set URLs to the proper domain name.

Remember this, because if you later (hopefully sooner) set your site to use HTTPS, you’ll need to update this.