Help uninstalling cloudflared on debian linux

I installed cloudflared on my debian system and I can no longer access any other software remotely. I’d like to uninstall it but

apt-get remove cloudflared

returns with

Package ‘cloudflared’ is not installed, so not removed

I Installed using these] instructions from https://pkg.cloudflare.com/index.html

sudo mkdir -p --mode=0755 /usr/share/keyrings

curl -fsSL https://pkg.cloudflare.com/cloudflare-main.gpg | sudo tee /usr/share/keyrings/Cloudflare-main.gpg >/dev/null

echo ‘deb [signed-by=/usr/share/keyrings/Cloudflare-main.gpg] https://pkg.cloudflare.com/cloudflared buster main’ | sudo tee /etc/apt/sources.list.d/cloudflared.list

sudo apt-get update && sudo apt-get install cloudflared

Any help is appreciated. I’m not extremely well versed in Linux command lines but I’m trying to learn.

This means that the software has already been removed. If you run which cloudflared do you get any output?

Additionally, if you’re still having trouble (after it’s uninstalled) you may need a reboot to completely flush it.

I get no response when I run which cloudflared. However when I run

sudo apt-get update

The first hit is

Hit:1 https://pkg.cloudflare.com/cloudflared buster InRelease

I’ve tried

sudo reboot

several times but still the same issue.

So apt-get update updates the package cache of your system. It doesn’t actually mean that the package is installed, it merely asks the remote repository whether there is an update.

To resolve this completely, you can run (make sure it’s exactly like that, a typo in this command can be bad):
sudo rm -rf /etc/apt/sources.list.d/cloudflared.list

You may have to enter your account password.

1 Like

Ah I see. Thank you for that. I ran the command and I assume it worked since now when I run

sudo apt update

Cloudflared is no longer in the list.

However, everything is still running at a snails pace. I don’t remember uninstalling cloudflared. I wish I had a backup right before I installed this so I could go back to what I had before.

This isn’t really a Cloudflare issue, but you can try running htop to see what is using resources. You might need to install it sudo apt install htop.

1 Like

Wow! That’s useful. I’ve been running a service called “sysmon” to achieve the same thing. This is way more convenient, thank you.

But you’re right, no line item for cloudflared so I’ll assume that its not causing any issues at this point. Thanks again for the help everyone.

2 Likes

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.