Help required with how to setup Noip ddns with cloudflare registered domain

Answer these questions to help the Community help you get started.

What is the domain name?
Have you searched for an answer?

Please share your search results url:

When you tested your domain using the Cloudflare Diagnostic Center`, what were the results?

Describe the issue you are having:
setting up cloudflare domain that uses noip ddns

What error message or number are you receiving?

name will not resolve to the ddns address
What steps have you taken to resolve the issue?

  1. installed noip DUC
    2.added a record
  2. read a lot of conflicting info onthe web

Was the site working with SSL prior to adding it to Cloudflare?

What are the steps to reproduce the error:

  1. pinged the address for the site
  2. ip is the cloudflare ip address

Have you tried from another browser and/or incognito mode?
no, I am using command prompt to view ip address

Then you need to fix this first. A site needs to load securely on HTTPS before you use Cloudflare.

Take a look at or Origin certificates.

No… but I expected to see the registered domain name to reflect the ddns noip domain.

This is what I have configured atm on cloudflare. I added the ddns ip address to see if it would redirect

Not sure what you said no to. Before you do anything with Cloudflare, fix the SSL issue on your server, otherwise that can’t properly work.

As for the hostname, you need a CNAME entry here and that should point to that .me hostname.

But again, priority should be the SSL setup.

Hi, thanks for your reply.

I have tried loading ssl certificate from cloudflare but after generating the api key and adding to the cloudflare plugin i get an error saying my domain is not registered with cloudflare.

Then i just tried to access my wordpress site via the url and the site had a padlock. under investigation its shows a google ssl certificate ??

You need to get the certificate from Once you got the certificate, configure it on your server.

Right now your server does not respond at all.

1 Like

Origin CA certificates · Cloudflare SSL/TLS docs has more details.

1 Like

That’s the proxy certificate. You need the certificate for your server. Follow the steps previously mentioned and make sure your server is properly configured, then it will work on Cloudflare.

1 Like

The server is a windows 10 system. Do i have to install the certificate in windows 10?

Yes, you have to configure the certificate on your web server. Please refer to the server documentation for details how to do that.

1 Like

I have created certificates and installed them within windows 10, however my attempts to port them into the wordpress environment have not been successful. I manged to lock myself out of wordpress for a while… which was a bit worrying!! I started to use a plugin called real simple ssl but this was going to create new certificates from a company called Let’s Encrypt, but thought that this would make things even more complicated and messy. I am now back in wordpress but the cloudflare plugin message is still there. The dns still points to and the ddns address is [ would this not have to be fixed prior to the chnage to ssl?

I am afraid the server still does not respond nor is there a certificate.

As long as the server is not working fine on HTTPS, it won’t work on Cloudflare either I am afraid.

Another thing you could also try is to use Tunnel.

In that way you do not need to update the address but your machine will actually connect to Cloudflare. But it is also a more complex setup.

1 Like

I will see if I can configure the tunnel option. Is this just a vpn to cloudflare?
Regards Kieran & thanks for you assistance… much appreciated

Not really a VPN, it’s an additional application you need to install on your server, which connects your web server with Cloudflare. As your server is actually connecting here, you won’t need to take the IP address into account, however you do need to maintain additional software.

And the credit for that suggestion actually goes to because for me it was forest → trees :slight_smile:

It may be the more elegant solution for your use-case as you do not need to deal with dynamic addresses, as long as you do not mind the Cloudflare service running on your server.

1 Like

Your screenshot has 2 DNS entries. --> -->

Both resolve. However the second entry points to a DNS record which does not exist and as a result Cloudflare can’t forward the requests anywhere. Thus it returns a 530 error when you attempt to reach the site.

Perhaps you meant to create an A record for -->

But without a valid root record for traffic can’t route anywhere. is a Cloudflare IP address. Cloudflare is a proxy. In order to proxy traffic it advertises an IP address on it’s edge to receive the request and proxies them to the origin.

That is aforementioned CNAME issue, which the OP may also want to solve, but that won’t fix the SSL issue.

./cloudflared.exe tunnel create cloudflarelink
2023-06-06T09:16:36Z ERR Cannot determine default origin certificate path. No file cert.pem in [~/.cloudflared ~/.cloudflare-warp ~/cloudflare-warp]. You need to specify the origin certificate path by specifying the origincert option in the configuration file, or set TUNNEL_ORIGIN_CERT environment variable originCertPath=
failed to create tunnel: couldn’t create client to talk to Cloudflare Tunnel backend: Error locating origin cert: client didn’t specify origincert path

I keep getting this error when setting up the cloudflare service…