Help please! 526 error on every single JS - APO enabled

Hi everyone,

SG hosted and SG optimizer plugin enabled + CF APO
Everything was fine until this morning I had a bot challenge on my IP… ?!

And now cache is bypassed and my WP website is completely broken.

Thanks a lot for any advice or help

Have you tried to disable Cloudflare APO?
Has your site already had an SSL certificate before it was added to Cloudflare?
Are you using official WordPress Cloudflare plugin or just the Cloudflare dashboard?
Any other caching plugins installed or not?

Thank you for your prompt answer
Yes APO disabled same pb
Yes but now it’s CF
Yes
Yes SG Optimizer and it worked great until this morning

Okay, thanks for feedback.
Have you already tried to Purge all the cache files from Cloudflare dashboard?
What SSL options enabled do you have under the Cloudflare dashboard?

Yes purged a lot
It’s working only when CF in dev mode…

When I try to open any file like https://pypo.eu/wp-includes/js/jquery/jquery.min.js, I got error Invalid SSL certificate.

Are you sure you have the valid SSL certificate installed on your origin?
Or, from screenshot as I can see, you use Full SSL (Strict), which could indicate that youa re using Cloudflare SSL at your origin?

Have you tried to switch to Flexible SSL? Does anything change?

At this moment, I can verify I can open the file https://pypo.eu/wp-includes/js/jquery/jquery.min.js. No error.

And your Website shows up now.

flexible ssl works better ! Thank you very much for the tip

1 Like

Well, Flexible SSL is not always a good option, but I am glad you have at least figure it out what it could be.

From my standing, you do not have an SSL certificate installed on your origin, or at least it is not valid SSL (maybe self-signed) but, yes.

There are tutorials if you wish to use Full SSL with the Cloudflare’s SSL certificate.

Or buy a dedicated one, and install it on your origin server.
Or you can generate an Let’s Encrypt and then use Full SSL mode.

Ok thx I’ll check at SG. I had a let’s encrypt there.
Thx again

1 Like

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.