Help on new domain myneangos . com and to redirect to another URL

Hi,

I need help on new domain that I just created myneangos.com and to redirect to another URL Free Webinar by Karl Serrano

I setup in DNS AAAA 2::1 and redirect rules as shown attached. I can only attached 1 image.

When I access www . myneangos . com from the browser, I was able to see the new URL genuineteam.net in the browser.

I still need the redirection because I don’t have a page

Is there a way to retain the URL www . myneangos . com and configure the redirection in the background?

Thanks
Maynard

The redirection settings look okay to me, but the domain does not have any A or AAAA records. You can add dummy records and mark them with the Cloudflare proxy icon as outlined here:

Hi,
I already configured @A and A configuration as shown attached.

When I open the browser, I can see the destination URL in the address instead of www . myneangos . com.

Is it possible?

Thanks.
Maynard

Hi,

I will rephrase my question here.

Source - www.myneangos.com
Destination - genuineteam.net

Currently, the redirection is working and I can see/display the destination URL in the browser.

But my primary question is, is it possible that the URL address in browser will retain to my source URL even after the redirection.

Thanks in advance.

UPDATE: You may also be able to use Workers for this. See this topic: Redirect domain with masking in page rules. Original response follows below.


That would be a rewrite (not redirect) with hostname override.

You’d use an origin rule for this, but the option to override the hostname (domain) requires an Enterprise plan. (If you have to ask, I’m going to assume you’re not an Enterprise customer.)

So, in short, it’s not possible.

Hi, I’m not an enterprise customer, so I may have to live with it. Thanks for your reply anyway and I appreciate it very much.

Hi, your recommendations to use workers in option 2 above is working here already. Below are the steps I had done.

  1. I disabled the Rules > Redirect Rules so that it will not trigger the one that I have configured to redirect earlier

  2. Copy the workers from Option 2 in your recommendation & edit the destination URL

  3. Deploy the updated workers in my dashboard

  4. Add workers routes so that if there is a request to .myneangos.com/ it will run the workers that I deployed

But there maybe workers limit usage of 100,000 requests/day, is this correct?

Thanks a lot for your help especially to GeorgeAppiah & Arun.

Best Regards,
Maynard

1 Like

That’s correct, for the free tier. You can, of course, pay for more (starting from $5/month). Find the full documentation here: Limits · Cloudflare Workers docs

NB: If this is for affiliate marketing, I’ll recommend you test it out thoroughly to ensure your affiliate cookies are being tracked correctly – so you don’t lose those juicy affiliate commissions.

Good luck!

1 Like