Help! New to Cloudflare, thought had set up the DNS settings correctly but email not working!

dns

#1

Hi,
I’ve setup the DNS settings for a few of my websites and they are all working fine, but having issues with my email.
I’ve copied the DNS settings from what is with my host company for that domain but the email is just not working. I connect using Outlook, and getting this message when trying to send an email :
Task ‘[email protected]******.co.uk - Sending’ reported error (0x80042109) : ‘Outlook cannot connect to your outgoing (SMTP) email server. If you continue to receive this message, contact your server administrator or Internet service provider (ISP).’
The only difference I can see is that on my host account for the MX settings, the host record is set as a @, on Cloudflare, it wont allow a @, it automatically changes to the domain name. Also TTL is at 14400 (as it is for all other DNS settings), they are all on automatic on Cloudflare and everything else seems to work, just not the email. Do I need to amend anything in Outlook itself as its going Cloudflare?
Anyone have any suggestions of what I am doing wrong? for info, I also cant receive mail either, sent mail sits my outbox then gives error message above.
Help!


#2

If you’re trying to use email through a DNS entry that’s set to :orange:, it won’t work. Cloudflare only proxies HTTP/S traffic.

Typically, a proper email server isn’t also your web server. It would be its own subdomain, and that would be set to :grey:.


#3

Thanks for your advice, some of the mail settings were set to the orange cloud, so trying to grey cloud them. Also, after speaking with my host company, as I have only recently set it up on cloudflare, they said it could be that the DNS settings are still going through propogation, so will try again later.
(at one point when we were changing settings, an email did come through to my outlook app on my phone that I sent as a test one but not to my desktop version, but the second test email I sent hasn’t come through on either, will try again after sleep lol!)


#4

This topic was automatically closed after 31 days. New replies are no longer allowed.