Help needed with 301 redirects

Hello, Cloudflare community!
Please, help me to wrap my head around a following problem:
I have two domains connected to Cloudflare and I want to set up 301 redirect from one to another:
from <landshaft.estate> to <кпландшафт.рф (Cyrillic domain to punnycode: xn--80aalwfnl3ar2b.xn--p1ai) >

but now only www.landshaft.estate is redirected to xn--80aalwfnl3ar2b.xn--p1ai

DNS records and page rules for landshaft.estate:


A bit of context: originally I’ve build Cloudflare workers site and connected it to landshaft.estate domain, but after a while I had to move it to Cyrillic domain, so I’ve connected xn--80aalwfnl3ar2b.xn--p1ai domain to Cloudflare and updated corresponding DNS records and page rules.

UPD:
Question on page rules work is closed, but in search for further help on bugged worker’s instance I’ve made new theme Bugged worker’s instance after routes changed

Seems like I’ve messed my worker’s site quite much - for some reason older site’s version is published at original (landshaft.estate) domain, though routes are changed to second domain:
workers-routes

Is it just a matter of time, or I should contact support?

Page Rules wont apply if we detect a Worker on the same route.

Thats why your page rule for ‘*.landshaft.estate/’ triggers, but ‘landshaft.estate’ does not as I suspect you have a Worker route on ‘landshaft.estate’.

For more reading, see here: How do workers combine with page rules? - #2 by KentonVarda

(Basically - ‘it depends’ on which Page Rules we’re talking about).

2 Likes

Thank you for help, @smarsh!
I guess, now I just have to find out how to get rid of a bugged workers site on landshaft.estate… As I mentioned before, I’ve changed routes for my workers site, and now I have two versions of the site online on two addresses.

Now, when I’m trying to change routing for my worker I face error. I’ve uploaded video here.

my wrangler.toml file

name = “landshaft-estate”
type = ‘webpack’
account_id = ‘48c55465bbce0e0e79c78482e7360690’
route = ‘’
zone_id = ‘dc2a4a64552696bad51becf21197b597’
usage_model = ‘’
workers_dev = true
target_type = “webpack”
compatibility_date = “2021-11-30”
[site]
bucket = ‘./public’
entry-point = ‘workers-site’

How can I get help with this kind of issue?

This looks like your concern, but it should not matter…much.

9da44d9c5433ec01066e0f83e7667b61886dd5a4

The first route is the default workers.dev hostname. The left circle is what you called your Worker. This can be renamed without hurting this. For example, I have a worker called “two-day-cache”. When I change the TTL, I rename it to one-day-cache, and all routes are automatically updated.

The righthand circle is your Workers subdomain. It can also be changed. Mine is a generic name. Yours is pretty much the same, but you named it after your business name. You can still change it.

I see you already have a Punycode route for that worker. None of the above should have any effect on whether or not that worker works. Personally, I have the BLAH.workers.dev route disabled.

The main question:
Is something not working?

@sdayman , thanks for your response!

I've tried to change the worker's name but faced error...

Same as I can’t disable BLAH.workers.dev route cause of mentioned above error.

Feels like I’ve messed up a lot : (

Speaking of not working:

  1. Page rules at my punnycode domain don’t work, however while site was on lanshaft.estate domain http → https redirect worked as intended.
  2. after I’ve changed route for worker’s site, site’s instance is “frozen” at original domain and can’t be changed.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.