Help me with https not working problem

Hi. I’ve gotten new domain: aadikar.com.np
Then I added it to cloudflare, and updated the nameservers.
image

I have SSL/TLS mode set to “Flexible”. And Always Use HTTPS enabled.
However, when i enter “aadikar.com.np” in browser, it doesn’t redirect to https.

If i enter “https://aadikar.com.np”, “Warning: Potential Security Risk Ahead” shows up.
The error is: MOZILLA_PKIX_ERROR_SELF_SIGNED_CERT

Suggest me some ways to enable https in my site : )

Can you try again now? Looks like it works, at least for me:

image

Yes, currently it works. I searched for hours on google about what was wrong, but it was just some small issue. sorry for trouble.

RewriteEngine On
RewriteCond %{HTTPS} off
RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

This code with .htaccess worked.

This topic was automatically closed after 30 days. New replies are no longer allowed.