Help me setup CF on x10


#1

I signed up for cloudflare via x10hosting’s cPanel option. I own a top level domain on GoDaddy which is parked on my x10hosting free plan. This worked fine until I added cloudflare, but now my website always returns an error:

SSL_ERROR_RX_RECORD_TOO_LONG

I have installed the wordpress cloudflare plugin and set everything up: the api key, recommended settings, purged cache, etc.

I’ve only registered for a cloudflare account today, but the SSL certificate display as active in the crypto panel.

Help, please :frowning:


#2

What SSL option have you chosen on the Cloudflare dashboard? Are you using Flexible? The other options require a certificate on your origin server. I think that error is related to server misconfiguration.


#3

Hi, thanks for taking the time to try and help me.

Cloudflare is set to Flexible, DNS on Godaddy is set to x10hosting’s nameservers, and cloudflare doesn’t even give me their nameservers on the DNS page, assuring me that that is handled via x10hosting’s partnership with them.


#4

You can try to setup Cloudflare manually (instead cPanel, if your host allow).


#5

Hi,

I signed up for an x10 account to try and troubleshoot this issue, but was unsuccessful at getting SSL to work under a variety of configurations. I believe the issue lies with x10’s server configuration but can’t confirm. I didn’t do much digging but this may be a known issue with x10’s free plan.

In most cases you get what you pay for, and I would urge you to seek out better hosting options if SSL is critical to your needs. There are several companies that offer cloud VPSs for as low as $2.50 - $5 per month. Or if it must be free you can do free (for 1 year) AWS VPS. I can elaborate if you wish but that is going a bit off topic at this point.

Sorry I couldn’t be of more help!