Help me debug \ fix dns (pass security check test?) in Firefox (sDNS, eSNI issue)

Was passing it long time ago just fine but now I have no idea what happened in my Firefox 74.0.1 (64bit) (Win 10) - something doesn’t work anymore (even on clean profile), sDNS and eSNI seems dead ? I’m out of ideas cuz about config settings are still the same:

network.trr.mode = 3 (tried 2 too) = true

maybe my ISP (Russia) strengthened DPI censureship settings and blocked things?

Check about:config for esni (should be set to True) and Firefox Preferences for DNS over HTTPS.

Checked those when I was writing the main post (my two settings in blockquotes)

  • In Chrome (latest stable 80.0.3987.163 ) I enabled secure DNS in about:flags there and it started working

from this:

to this:

but Firefox’s option to enable it doesn’t seem to enable secure DNS?

Ah, yes, you did post those options. As you can see, they work for me, so Cloudflare isn’t blocking it.

I have same issues, appeared just recently within a couple of weeks. Tested different ISP, like mobile phones, it looks like my home ISP is doing this. Also to note, reCAPTCHA services currently stopped supporting mobile mozilla browsers, which is very suspicious.