Help! Lost My DNS Records, Not Getting Email


#1

Hello there!! I just starting using Cloudflare last week in order to use Kajabi. My website is working, however, I can not receive emails. I believe I accidentally deleted my DNS records when I made the switch. My domain is through Google Domains. Can someone look at my DNS records to see why I can’t get the emails?

I tried to add some of them back but no luck. I also see the note “An A, AAAA or CNAME record was not found pointing to the root domain.” I’m not sure how to do that since I do not know the ip address of the domain.

Thanks!

Here is a screenshot

.


#2

You can rig up a non-www entry: Add an A record with @ in the first box, and 216.58.217.206 in the second box. That IP address is Google, but you won’t be using it because: Set that entry to :orange: and then go to Page Rules and add one to match mediationdirection.com and set it to Forward (301) to http://www.mediationdirection.com (or https if that’s what you’re using). Docs here say you can leave off the http or https portion for the match, though I haven’t tried that.

As for the MX records, the ones you have look ok, but I believe Google tells you exactly which ones you should use. Do mail senders get bounces?
EDIT: Ok, it looks like everybody using Google should use those MX records, so it looks ok.


#3

Thank you so much @sdayman! I did everything you said. There has been a change. Email senders are no longer bounced back but I still can’t receive the emails myself. In Google Domains I have email forwarding setup so that emails sent to [email protected] is going to my personal email address. Also in the Google Domains setup I see the message “It looks like you’ve changed your name servers. All settings for your domain (including website, email, synthetic records and resource records) are currently disabled.”

Any ideas?


#4

That’s not an encouraging message. I hope Google doesn’t get all bothered that you’re not using their DNS, then shut down your services. Hopefully they’re just talking about the DNS settings you had there.

Maybe someone here uses Google domains and can answer your question.


#5

I just talked to Google Domains. They said that the message is there because in order for Google to forward emails, it needs to go through their name servers. Since I’m using Cloudflare name servers Google email forwarding is disabled. Google support said,

  1. I need to setup email forwarding through Cloudflare
  2. Or, if that is not available, I need to point meditationdirection.com to Cloudflare’s Ip address.

I have no idea what Cloudflare’s IP address is.


#6
  1. Cloudflare doesn’t forward email, so this isn’t an option

  2. Cloudflare’s IP addresses can change and Cloudflare will remove your domain setup if you’re not using a Cloudflare Name server, so this isn’t an option (I believe Google’s response means to use Google’s name servers, but plug in Cloudflare’s IP addresses for your domain)

  3. Set up an email forwarder elsewhere. For example, my domains are registered at Hover. For $5/year per address, they’ll forward my [email protected] to my personal email address. I have a CNAME for for mail.example.com that points to mx.hover.com, and my MX record is mail.example.com

That last bit rambled a bit, but the point is, use another service to forward your email.


#7

@sdayman Thank you so much! Problem solved! I went with Mailgun since it was free. I also found an article that had very clear instructions for setup in Cloudflare and Gmail. I will leave it here for anyone having a similar problem. https://www.chrisanthropic.com/blog/2014/mail-forwarding-with-mailgun-and-cloudflare/

Thanks for your time, care, and knowledge. I had a product launch and it was the worst timing ever not to be getting emails.


#8

This topic was automatically closed after 14 days. New replies are no longer allowed.