Help! I get a 403 error!

Ok, the site I am managing is constantly giving me 403 errors, Its getting so hard to test my site, and all my visitors are constantly getting an error. I was told previously that this is an error on my hosting providers side, but they seam to think its a Cloudflare issue, since my .htaccess file seams to be fine. (They think that the DNS records are messed up of something.) I tried connecting to my site via VPN and Private mode, but these errors still pop up! My nameservers from my domain are pointed to Cloudflare, and an “A” record points Cloudflare to my site. I can still update my site, so I know visitors are still seeing the updated site, but links everywhere are pointing to my 403 error page!
My DNS records at Cloudflare:

My site:
Links that lead to and error page:

  1. Click “Products”, its supposed to bring you to, which re-directs you to (A page that does work), but an error is shown instead when you try and go to
  2. Click “Contact”, its supposed to go to, but an error is shown instead.
  3. This happens on a lot of my products to! ex.
    Help! Thanks!

I am afraid that’s something you need to clarify with your host, as that 403 comes straight from your server (not only because it’s not proxied). Cloudflare can’t do anything here as they are not involved in the first place.

Ok, That what I thought the response was going to be. Would it work if I created 4 nameservers with my domain register (Namecheep)? The top two for Cloudflare, and the bottom two for my hosting provider?

Not really.

  1. When you are on Cloudflare you can only use Cloudflare’s nameservers.
  2. It is not a DNS issue in the first place. The server returns that 403 for some reason and you will need to find out why (most likely with your host’s help).

Ok, I will bring it up with them again, thanks for your responce!

You can also show them this output as further evidence that it’s not Cloudflare related but comes from their server.

$ curl -I
HTTP/2 403
server: nginx
date: Fri, 19 Mar 2021 15:03:35 GMT
content-type: text/html
content-length: 146
vary: Accept-Encoding
1 Like

403 means forbidden! If you’re seeing a 403 error without Cloudflare branding, this is always returned directly from the origin web server, not Cloudflare, and is generally related to permission rules on your server. The top reasons for this error are: 1. Permission rules you have set or an error in the .htaccess rules you have set 2. Mod_security rules. 3. IP Deny rules Since Cloudflare can not access your server directly, please contact your hosting provider for assistance with resolving 403 errors and fixing rules. You should make sure that Cloudflare’s IPs aren’t being blocked.

Cloudflare will serve 403 responses if the request violated either a default WAF rule enabled for all orange-clouded Cloudflare domains or a WAF rule enabled for that particular zone. Read more at What does the Web Application Firewall do? Cloudflare will also serve a 403 Forbidden response for SSL connections to sub/domains that aren’t covered by any Cloudflare or uploaded SSL certificate.

If you’re seeing a 403 response that contains Cloudflare branding in the response body, this is the HTTP response code returned along with many of our security features:

  • Web Application Firewall challenge and block pages
  • Basic Protection level challenges
  • Most 1xxx Cloudflare error codes
  • The Browser Integrity Check
  • If you’re attempting to access a second level of subdomains (eg- *.* ) through Cloudflare using the Cloudflare-issued certificate, a HTTP 403 error will be seen in the browser as these host names are not present on the certificate.

If you have questions contact Cloudflare Support and include a screenshot of the message you see or copy all the text on the page into a support ticket.

1 Like

Thanks everyone for your help! I managed to solve the issue, (Turns out it was the .htaccess file the entire time). Thanks for everyone’s tips and ideas!

:grinning: Glad the issue is resolved!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.