HELP I did everything correct - and cannot get SSL to work on site

Help Im extremely frustrated with Cloudflare SSL,
I have already configured multiple SSL certificates and this is the first time its giving such a hard time.
So I need full encryption not just flexible. I installed everything and followed everything according to these instructions in Digital Candy - SSL Encryption with godaddy cpanel. My certificate is added on my server correctly. This is the website https://bodyarmormedical.com the certificate does not show like my other sites. This one shows its invalid.

This is how it looks like http://prntscr.com/rdzjuj
Also its showing as Expired since November 13th 2019 ( This used to fix itself )

I triple checked and the origin certificate has been properly installed on the cpanel hosting

Traffic is proxied through cloudflare

my ssl encryption mode is full

so everything checks out but STILL the certificate shows as expired and its showing as not secure :frowning: can someone please help

image

The site is not updating the certificate also why does it show expired?

The main issue is Mixed Content. It also doesn’t auto-direct to HTTPS. You can set this from the SSL/TLS settings under Edge Certificates (Always Use HTTPS).

What you’re seeing is due to you connecting directly to the origin server. Perhaps you have a local Hosts file. Or your DNS hasn’t refreshed with Cloudflare’s DNS info. For the rest of us, it’s working, save the Mixed Content issue.

If you look in the Origin Server section of SSL/TLS settings, do you see an Origin certificate with the November '19 date?

let me take a look really quick

It expires 3/10/2022

I actually don’t see any certificates that expired 11/19

Also all traffic is going through proxy

image

That’s even more interesting. It looks like your browser connected direct to origin server, yet your origin cert date doesn’t match. And I’m not even sure your browser is connecting to the correct origin.

For the rest of us, your site works, for the most part.

Now you have two issues to track down:

  1. Why you’re not connecting the same way as the rest of the world does.
  2. Fix that Mixed Content.

https://www.dotcom-tools.com/website-speed-test.aspx#62BC2953F14A4907B9AF16CD740D1137

Does the certificate show as invalid for you as well?

There are no problems with the public certificate.

Another weird thing I put this setting but website is still not forwarding all requests to https

and also Full Encryption Mode

Yes, it does.

this is very weird and never happened to me before could this be a server issue?
I added Really Simple SSL plugin to WP site and all looks well,
but my Chrome still shows as Not Secure lol

Debug shows all is good