Help! HTTPS Not Working Correctly

Hey Everyone!

Hope you are having a good holiday so far, I just had a problem. I use the domain: and I set the website up by using an Oracle Cloud server and then using Hestia Control Panel and then installing Wordpress while connecting it all to Cloudflare. I don’t really know how to explain this, but I followed this video: which goes with what I did in Cloudflare exactly.

The Problem:

Currently, you can visit my site using both and you’ll be greeted with a Wordpress sample page. If I just type in my browser, it will spit out the http one instead of https one. I tried enabling Always HTTPS, but it just completely broke the site as I couldn’t reach both the http or the https. I can’t even access the page and it shows up as redirecting me too many times. I don’t know if I am using the wrong type of certificate or doing something other than that, the video above is exactly what I did on Cloudflare.

Thanks again for your support!
Happy Holidays!

Visit the SSL dashboard and check your SSL encryption mode setting - it should be to be set to Full (Strict).

If you encounter an error when loading your website with Full (Strict), visit SSL/TLS > Origin Server and follow our deploy an origin CA certificate guide to install a valid certificate on your server - this will allow you to use Full (Strict).

If you cannot install a valid certificate on your origin, you can downgrade your SSL encryption mode to Full as an alternative. As a last resort you can choose Flexible however if you continue to see redirect loops you will need to fix that issue at your origin server. Read our Too Many Redirects guide for further information.

1 Like

Thanks! The Full (Strict) seemed to do it for me, I was on flexible!


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.