Help! How do I get Google Domains Email forwarding to work with CloudFlare DNS

I recently setup CloudFlare to speed up traffic for our wordpress site. While doing it, I broke email forwarding. Here are the steps I took:

Before CloudFlare:

  • I configured Google Domains, our domain registrar, to do email forwarding
  • I used Google Domains DNS to forward all http(s) requests to our wordpress host
    Status: Emails are delivered and website is receiving traffic

After CLoudFlare:

  • Google domains is still configured to email forward
  • Google Domains is setup to use CloudFlare custom DNS servers
  • When adding my site to CloudFlare, CF automatically got the Synthetic MX records from Google. I confirmed that they match.
    Status: Email are NOT being delivered. Website is receiving traffic via CloudFlare.

Here is a screenshot of the CF MX records:

Here is a screenshot of the Google MX records:
https://bit.ly/2VoMp8f

Please help me resolve this. This is my third attempt at this.

Thank you, Prasad

1 Like

I don’t believe you can use alternative DNS for forwarding e-mails with Google Domains. The NS must remain with Google to do that as far as I know.

While that is enabled, if you go into the e-mail forwarding settings on Google Domains it says:

All settings for this domain are disabled and can’t be changed. To enable them, restore the default Google Domains name servers.

You can only do that with a domain that is still registered with google domains they require you to know what email is forwarding to the other email so you must register on google domains for this to work.

Email @ .net cannot know you want to point to
Email @ .com without google domains

This URL tells you everything that you need to know if your domain is registered on Google domains

Or

https://improvmx.com/guides/cloudflare/ (Free)

To use Gmail you can do this I could not post the MX recorded because of my two link max.

Set up email forwarding with custom name servers

Add the following MX records at your DNS From URL one!

Hi you can now just go down to email forwarding on this how too.

Set up email forwarding with custom name servers

Add the following MX records at your DNS host, if you’re using custom name servers and want to use Google Domains’ [email forwarding]
Found the google how to
https://support.google.com/domains/answer/9428703

Try trying off the CloudFlare proxy next to the Contented cname in your photo by clicking on the orange cloud to the right it will become gray and not affect your setup Also you have a different MX setup then google show in my reply below

Got it here. https://youtu.be/O5wOg725xkA

About 12 hours after I posted my original question, everything started working. My guess is that the DNS propagation takes a while if you are just using google domains for email forwarding.

Thank you everybody for trying to help me resolve this issue.

1 Like

Congratulations my friend!!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.