Hello Universal ssl has been pending verifivation for over a week, my registrar was bluehost and moved to cloudflare , any advices?

Answer these questions to help the Community help you with Security questions.

What is the domain name?
mohamaditani .com

When you tested your domain, what were the results?
ssl_error_no_cypher_overlap
403 forbidden
err_quic_protocol_error

Describe the issue you are having:
universal ssl is stuck on pending verification, its been more than a week, so that I had to change registrar from bluehost to cloudflare, but the ssl pending issue wasnt fixed
this domain is just a pointer to a kartra account , and should redirect to https:/ /mohamaditani .kartra. com/page /GAb35

I

What error message or number are you receiving?
403

What steps have you taken to resolve the issue?

  1. switched website to cloudflare
    2.paused clouldflare, then resumed it
  2. disabled https for 3 hours then re enabled it

Was the site working with SSL prior to adding it to Cloudflare?
I had a hosting plan on bluehost, but wasnt using it, the error started when the plan expired

What are the steps to reproduce the error:

  1. mohamaditani .com

Have you tried from another browser and/or incognito mode?
yes
Please attach a screenshot of the error:

Hi there,

Sorry for the issues you are facing. If I query the site now, it looks like SSL has been provsioned and am able to complete a TLS handshake - as you can see below.

  • Server certificate:
  • subject: CN=mohamaditani.com
  • start date: Jan 31 21:08:04 2024 GMT
  • expire date: Apr 30 21:08:03 2024 GMT
  • subjectAltName: host “mohamaditani.com” matched cert’s “mohamaditani.com
  • issuer: C=US; O=Let’s Encrypt; CN=E1
  • SSL certificate verify ok.
  • using HTTP/2
  • [HTTP/2] [1] OPENED stream for https://mohamaditani.com/
  • [HTTP/2] [1] [:method: GET]
  • [HTTP/2] [1] [:scheme: https]
  • [HTTP/2] [1] [:authority: mohamaditani.com]
  • [HTTP/2] [1] [:path: /]
  • [HTTP/2] [1] [user-agent: curl/8.4.0]
  • [HTTP/2] [1] [accept: /]

GET / HTTP/2
Host: mohamaditani.com
User-Agent: curl/8.4.0
Accept: /

< HTTP/2 403
< date: Thu, 01 Feb 2024 14:29:58 GMT
< content-type: text/plain; charset=UTF-8
< content-length: 16
< report-to: {“endpoints”:[{“url”:“https://a.nel.cloudflare.com/report/v3?s=ApA7lR6ALkqKxiM05SFX6ff5Flq5%2B1ge3WkWLm%2FTjcWrKtC7v%2FIwJiGoTa%2B0GBHnsnwHC4vYg8klSpLAu1EAJrOtPQzPKhpVlyNCx9g6%2BpJmh7lHiX%2BH4LvzL2xdAT5BdylD0XRxyLG%2BUr0%2BWKNd”}],“group”:“cf-nel”,“max_age”:604800}
< nel: {“success_fraction”:0,“report_to”:“cf-nel”,“max_age”:604800}
< x-frame-options: SAMEORIGIN
< referrer-policy: same-origin
< cache-control: private, max-age=0, no-store, no-cache, must-revalidate, post-check=0, pre-check=0
< expires: Thu, 01 Jan 1970 00:00:01 GMT
< server: cloudflare
< cf-ray: 84eae3bf9ec45407-YYZ
< alt-svc: h3=“:443”; ma=86400

I still get the 403, but this looks to be because of a cross-user CNAME ban:

You would need to review your DNS records here to ensure you are not CNAME’ing your DNS record to another hostname in another Cloudflare account, as this is prohited. Unless the target hostname you are pointing to is configured to use Cloudflare for SaaS and configured your hostname as a custom hostname - Cloudflare for SaaS · Cloudflare for Platforms docs

Hope this helps!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.