Header not found, check if Geo feature in CloudFlare is enabled

Good morning
I have this problem:Header not found, check if Geo feature in Cloudflare is enabled
I put <?php if (isset($_SERVER['HTTP_CF_CONNECTING_IP'])) $_SERVER['REMOTE_ADDR'] = $_SERVER['HTTP_CF_CONNECTING_IP'];?> in my wordpess php header but it doesn’t work
Help please

Check that the DNS record is proxied and not set to “DNS only”, so the request is going through Cloudflare to create the header.

Check if you/your host is already using cf-connecting-ip to restore visitor IPs, in which case REMOTE_ADDR may already be set to the client IP.

I don’t know how to do, i am in OVH, can you help?

What is your domain?

Can you create a test page that shows all the request headers?
https://www.php.net/manual/en/function.getallheaders.php

test.galenusrevista.com and galenusrevista.com, Thanks

here the header :
https://www.test.galenusrevista.com/test.php

There are Remote-ip and X-Forwarded-For headers as it seems your host or a plugin is already translating the cf-connecting-ip header. (This is best as you should only trust cf-connecting-ip if coming from a Cloudflare IP address, otherwise it can be spoofed).

You also have Cf-Pseudo-Ipv4 enabled which is a way of getting IPv6 addresses into an IPv4 format for compatibilty reasons. I suggest you turn it off and use the real IPv6 address passed through.

I put Overwrite Headers in IPV4 coulflare but it seems not working : (

and if i go to https://www.test.galenusrevista.com/jaypirca-adtech-49064-728x90/ i have an ssl error from chrome ; in mozilla it’s work

This is a second-level subdomain, which is not covered by the Cloudflare Universal SSL (that covers galenusrevista.com and *.galenusrevista.com). You’ll need to use an advanced certificate to cover www.subdomain.example.com.

If i buy a Cloudflare Universal SSL, it will not resolve the problem, isn’t it?

Cloudflare Universal SSL is the default setting and is free. But it won’t cover a second-level subdomain for which an Advanced Certificate is needed.

sorry, with an Advanced Certificate, it will resolve that? :slight_smile:
There are Remote-ip and X-Forwarded-For headers as it seems your host or a plugin is already translating the cf-connecting-ip header. (This is best as you should only trust cf-connecting-ip if coming from a Cloudflare IP address, otherwise it can be spoofed).

You also have Cf-Pseudo-Ipv4 enabled which is a way of getting IPv6 addresses into an IPv4 format for compatibilty reasons. I suggest you turn it off and use the real IPv6 address passed through.

The Advanced certificate is for your SSL issue on www.test.galenusrevista.com, it’s nothing to do with the headers.

For the headers, I gave you all the information.

Sorry
For IPV4 i change but for this , i don’t know how to do it :
There are Remote-ip and X-Forwarded-For headers as it seems your host or a plugin is already translating the cf-connecting-ip header. (This is best as you should only trust cf-connecting-ip if coming from a Cloudflare IP address, otherwise it can be spoofed).

Boa tarde
Nao estou conseguindo configurar o meu dominio
pode me ajudar por favor