hCaptcha does not load

I have set hCaptcha for a wiki based on MediaWiki 1.35 according to these instructions: https://www.mediawiki.org/wiki/Extension:ConfirmEdit#hCaptcha

The hCaptcha does not load. Could this be an issue with Cloudlfare or should I search elsewhere?

Hi @CostasAthan,

Have you tried pausing Cloudflare to see if the issue remains?

You can pause Cloudflare from the Overview tab of the Cloudflare Dashboard, bottom right under Advanced Actions.
If the issue persists after Cloudflare has been paused, it means that there is an issue with your origin, Cloudflare is only operating as your DNS provider while it is paused.

@domjh

Actually, I hadn’t try it.

I tried to do it now, but disabling Cloudflare led to connection failure because of HSTS security policy. I disabled the relative extension (https://www.mediawiki.org/wiki/Extension:HSTS), but the problem persists and connection continues to fail giving me the same reason (HSTS security policy).

Now, I guess I have to troubleshoot this problem before dealing with the hCaptcha issue.

@domjh

OK. Connection failure persisted after the extension’s deactivation, because of browser caching.
I finally succeeded connecting to the website while Cloudflare was paused.
hCaptcha did not load. That means that Cloudflare is not causing the problem. The cause may be the origin server, the MediaWiki software, a conflict with another extension or hCaptcha itself. I have more troubleshooting to do…

Thanks for the help!

This topic was automatically closed after 14 days. New replies are no longer allowed.