Having problems with receiving sending & configure emails in Mail App

dns
wordpress

#1

I am new and need help. How I can enable Hostgator’s name server to be pointed at Cloudflare so I can start receiving and sending emails?

My domain name is registered with 123-reg.co.uk. My website host is with Hostgator, and I have pointed my name server to Cloudflare. Now, I am having problems to receive, sending and configure email settings in Mac Book Mail App.

I have read all the discussions, the supports in the Cloudflare community and googled it, none of the methods are working anymore.

I also spent days trying to get Hostgator to help me install the Cloudflare in my cpanel, which they rejected my request. They openly admin they no longer support Cloudflare. So all their previous articles about Cloudflare are not valid! (http://support.hostgator.in/articles/specialized-help/technical/cloudflare/what-is-cloudflare-how-do-i-enable).

I have followed the instruction changing MX records, change A mail pointing to Hostgator site IP, none of which enable my emails to back. I don’t want to revert my name server back to Hostgator just for the sake of the email problems. Please see the settings I have for the MX records:

.
I really don’t know what else I can do to get the email setup


#2

I am not pretty sure but it looks, like there is your HG hostname resolved or wherever this entry is set.

;; QUESTION SECTION:
;healthbeautystore.co.uk. IN MX

;; ANSWER SECTION:
healthbeautystore.co.uk. 297 IN MX 0 dc-2eb84a2278de.healthbeautystore.co.uk.

;; Query time: 1 msec
;; SERVER: 1.1.1.1#53(1.1.1.1)
;; WHEN: Tue Apr 03 14:16:28 CEST 2018
;; MSG SIZE rcvd: 84

I cant see any reason why your MX is pointed to dc-xxxxxxx

According to this article:
http://support.hostgator.com/articles/mail-exchange-record-what-to-put-for-your-mx-record
(I do NOT have HostGator name servers, how do I point my email to HostGator?, bottom of the page)

you need to add your assinged Hostname as A-Record here and point the MX to it.


#3

I think based on the screenshot all you need to do is change the :orange: next to mail to :grey:. We don’t proxy SMTP or POP3/IMAP ports so you’ll want those to go direct and not through Cloudflare.


#4

Thanks Mark. Really appreciated your help.

I have followed the step yesterday, and tried again today from HG’s guide as per attached, there was an error code of 1004. It asked me to create A record with my assigned IP address, which it is already there by default in Cloudflare. When i tried to point MX to it this is where I see the error code 1004.

While this method does not working. On the Mac Mail App. I can’t connect on Hostgator email trobule shooting, it says “Unable to contact name servers registered for the healthbeautystore.co.uk domain name”. So this triggers Mac Mail app not able to connect on the HG email.

I am really running out of options. This is the biggest headaches I ever encountered. All others I can explain the problems and find solution. For this one? I can’t even begin to explain the whole problems.


#5

Thanks! it works! Finally. My headache is gone! what a whole lots of bulls. Spent days, this trick works.


#6

This topic was automatically closed after 14 days. New replies are no longer allowed.