Having problems with CloudFlare from My IP address


I’ve have a static/public IP address which I use to surf internet.

Every time I have to surf a website having cloudflare activated I’ve problems: The site is slow and web-site content sometimes isn’t full loaded (In particular for CSS and JS files).

When I try to connect using a VPN or another IP address there are no problems.

Is it possible to solve this problem for my IP address?

I’m a web developer and I also work on many websites having cloudflare activated.

Hm, maybe your ISP is throttling your connection?
Or, as you are developer, do you have HTTP/3 enabled in FireFox maybe, if using this Browser or some other?

Can you try checking one of these sites at example.com/cdn-cgi/trace and check the “colo”? It should return a location near you (it uses Airport codes instead of city names).


I think it’s not a browser issue, because if I just connect using the same browser with a different IP address, everything works ok.

The only websites where I have problems is where cloudflare is activated, so I don’t think my ISP is throttling my connection (I would have this problem in all websites).

Sorry I tried to click on it but I get only “Example Domain”, what should I do?

I doubt example.com is one of the domains in question. But you didn’t list any domains, so I just provided an example of what you should do with an existing domain with the problem.

1 Like

Sorry, at first I didn’t understand.

I’ve tried what you wrote and I get:


For two websites.

Thank you

That’s Milan, so I guess that’s close to you. @matteo is the expert on Italian traffic through Cloudflare.

What ISP are you using? What kind of connection?

Also, what’s the result you get from https://speed.cloudflare.com?

1 Like

Hello Matteo,

My ISP is Fastweb. I use always ethernet connection (no wifi).

Here the details about the speed test:

Lucky you, going to MXP with Fastweb is a treat…

Given the results I honestly can’t tell you why. My only idea would be to try and disable IPv6, which might cause some issues given how it’s implemented. It should be a toggle in the default Fastweb router.

1 Like

thank you, I’ve disabled the IPv6 on LAN

I will try to understand in these days if there are any improvements.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.