Having issues with SSL certificate for mail server

Hello, I am using cyberpanel and I issued SSL for my domain and mail server it worked fine for few days and I added my website to cloudflare and suddenly mail server lost SSL and emails are not being delivered due to this, when I chatted with cyberpanel support they said DNS records are extra on my cloudflare, I do not know what is causing this issue, I was able to issue SSL for mail domain yesterday night and it worked fine until morning and the same issue again. please let me know if anyone has gone through this issue in the past. this is driving me nuts.

Any help would be appreciated…

Make sure the DNS record for your mail server is set to :grey: DNS Only.

Yes, I removed proxy from all the DNS records and I can show the dashboard screenshot





I can confirm that the ‘mail’ record points directly to a Hostinger server. In that case, they should be able to issue a certificate for that hostname. Or cyberpanel. Your entire domain is DNS-Only, so the only thing Cloudflare is doing here is publishing DNS records, like any other host would.

Actually they said there are extra DNS records on cloudflare, there are no issues with host name SSL or domain name SSL, it is happening with mail server, I am having to issue SSL everyday to solve this issue, there is a limit for issuing SSL through cyberpanel, can you help me in resolving this?

Cloudflare will do whatever you’d like with DNS records. If Cyberpanel says you don’t need certain records, go ahead and delete them.

As Cyberpanel is not a Cloudflare product and nothing is proxied, there’s not much we can do other than assist with your DNS records.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.