Have You Managed to Transfer Any Domains Today?

Yeah yeah, sooner or later they will get to it!

I would very much appreciate that @Sascha, as I’m sure would any other users having the same problem.

I feel that this is a significant enough problem to justify some sort of official communication from the Registrar team. There are clearly dealing with many problems, but not being able to accept domains into your system should surely be a priority. They should not only get to it sooner (rather than later), but they should also let their users know that they take it seriously.

I believe that they do take it seriously, I personally talked and resolved some issue in previous waves with the PM for Registrar (@SamRhea, if you want to address and/or request things) but they would probably have a list ordered by number of people involved.

I (and others) for example had an issue where the billing system negated the transaction if there were a dedicated certificate active on the domain. Completely unrelated to my payment method and to the actual Registrar product.

Yeah, I agree, I am confident that payments are not the problem.

In fact, payments are the one part of the process where they actually have informative error message: early on, I had entered the wrong expiry date for my credit card and the system let me know exactly what the problem was when I tried to initiate my first transfer.

I wish the rest of the process would give some sort of clue about the type of failures it is having.

It does but it’s not displaying in the UI (don’t ask why, they should do so, but I can’t do anything about it).

If you check in the Dev tools there is a JSON response saying the error a bit more verbose.

1 Like

Yeah, I figure they must be aware that it is important, what I am saying is that it is also important to express to your users.

Yeah, I have seen that @SamRhea was good at improving the situation where users with more than 20 sites on Cloudflare could not use the registrar system at all, he increased that limit to 250 sites.

What worries me is that they barely respond to feedback from experienced domain owners about problems that make their system far harder to use than any other registrar’s system, such as the need to manually deselect 249 domains when you want to transfer only one, or the mystifying decision to list domains in alphabetical order rather than by the more logical (in the context of domains) order of expiry.

I get that they are busy, but as it appears that they do not know much about how domain owners operate or what they need, that feedback could be of value to them, it might be worth their while to encourage it.

Thank you @matteo, I will try that.

1 Like

The list order thing I believe is due to the fact that when they list they don’t have the actual expiry date available. They will fix that, but gathering millions of expiry dates is unreasonable at the moment… The UI will be improved upon and iterated on.

They are at the first stages of beta rollout, give them some time. If you need clean UIs you can hold off one year, wait and see at your current registrar.

… but the expiry date is included right there in the list :smiley:

I think this is a purely UI problem, in the sense that presenting that same list, with no more than the data it currently contains, but using a re-orderable table, would instantly boost its usefulness, as would a simple checkbox to mass select or deselect all the domains in the list.

What I am trying to do is give clear, strong feedback that reflects how important this stuff is for actual users. I do that because I want Cloudflare to be a realistic alternative to the existing registrars. I do not agree that they will automatically get this stuff right over time, not without feedback from experienced domain owners.

It was very clear to me, just by looking at the initial design decisions they have made, that no-one on the team really understands how most domain owners operate, that they did not seek out that knowledge and that they did not have the humility to look at how other registrars have solved the same problems. I to add my feedback to the mix because this is stuff I have been dealing with daily for over two decades, I want to at least give them the option to consider why some decisions make their system worse than it needs to be.

Yes, I could have just waited a year at my current registrar, no problem, but I think you are wrong to presume that will magically have a better UI by then. A far more likely evolution, if I had not got involved, is that they would still be unusable by users with more than 20 sites on Cloudflare, and the only people keeping their domains here would be those to whom saving 50 cents a year is more important than usability (which, to be fair, will be enough people for the project to be considered a success).

I want it to be better than that.

If I remember correctly they do an async API call there to get those, they would have to reorder the list after having it already displayed. They should maybe allow for it to be reordered.

More or less, agreed.

We all do, they included. I really hope @SamRhea reads this and takes it into consideration. I would imagine getting things working (and with 200+ TLDs isn’t all that easy I presume) is priority number 1, then usability and polishing touches.

1 Like

Hi everyone!

Sam here. Lots to cover in this thread, so I’ll do my best to respond to each point.

  1. Mystery failures where “Something went wrong”

I agree - this is a really inconvenient and annoying error after going through the trouble of entering auth codes and unlocking domains. While several thousand domains have transferred to Cloudflare successfully since launch, we’ve seen this error impact a small percentage of transfers. It seems more concentrated within a given account, which is why a single account would have a higher proportion impacted. Additionally, domains with dedicated certificate subscriptions tend to hit this error.

We’ve identified a fix for this issue and will be deploying that change in the next couple days, probably as early as this afternoon. The HAR files submitted allowed us to isolate what was failing and address it, and we’re grateful for those that sent the details!

We are still seeing some cases where card issuers reject multiple independent charges, but that is unrelated to what we believe is causing this error for those reporting it in this thread.

  1. Manual domain selection / domain listing

We understand that you might not want to move every domain over at the same time, but removing each domain manually is a chore. We’re looking at adding that feature soon. Making this more useable for different types of domain portfolios is a priority.

  1. Expiration date

WHOIS responses contain two expiration date fields - one in the primary response and the other in the contact-specific response. The contact-specific response was using an incorrect value. We’re deploying a fix for this as we speak, should be available in the next couple hours.

Thanks for the feedback and commentary; it’s valuable. We’re definitely committed to making this system useful and intuitive for domain owners of all sizes.

Sam

5 Likes

Terrific response, thank you.

@imappoet

I was finally able to transfer my domain. So you may give it a try now and see, if your issues are fixed, too now.

1 Like

Thanks for the update @Sascha, good to know that there is light at the end of the tunnel, the Registrar team are clearly making progress in mopping up the remaining problems.

I tried again but am still getting 422 (Unprocessable Entity) responses.

I submitted a support ticket two days ago, and have sent a HAR file, hopefully someone at Cloudflare will see the ticket and be able figure out why their system is no longer able to process my domains. Your result gives me a lot of hope :smiley:

I still can’t transfer.

Do you get an error? Has it not reached your wave yet? Any more info would be useful!!!

Hi All,

This is my first time posting to this community!

I successfully transferred one *.net domain over the weekend, and it was quick and painless. I have also been trying to transfer two *.xyz domains since last week.

Each time I start the process the losing registrar says they don’t see the transfer request. I keep triple checking domain privacy / auth codes etc, and have now attempted the transfer 4 times for each of them.

It is feeling like the Cloudflare system isn’t actually sending the request to the registry for *.xyz domains.

Has anyone successfully transferred any xyz domains?

J

I know @eva2000 or @sdayman did, any help guys?

Hey @james.miller - that’s frustrating. We’ve had several users transfer .xyz successfully, so definitely want to figure out what the issue is with your registrar.

Which registrar is it? And when you initiate the transfer, does the stats update to “Pending Approval”? One last question - how long did you wait after you initiated the transfer before you cancelled?

Thanks for the prompt response, very much appreciated. I’m currently with NameCheap, but the transfer process isn’t identifying that correctly.

The first time I started on Friday afternoon, and waited for a few hours. I also did a .net, and it went straight through, so I tried again a few hours later for the xyz.

I then waited until Sunday afternoon / evening before trying again. I had gone back and forth with both Cloudflare and NameCheap support and both kept saying it was the other party.

I then did more back and forth over the next few days, and I then on the advice of both I have now tried a 4th time. It is now Thursday morning.

The .net domain correctly identified it was NameCheap straight away, however for the xyz domains it never shows anything other than the below:

Status: Pending release from previous registrar
Registrar: Unknown (Centralnic-H1772673)

The fact it says unknown registrar doesn’t give me a good feeling for success.