Have to type www. before my website name in order for it to say secure

Hi,

My site will say: Not Secure if I DON’T type [www.] or (http://www.) before my website or. If you type www. or http://www. before my site name it says that it’s secure. I can’t figure out what the problem is and would really appreciate anyone’s help! I spoke to my website host and they said that I needed to add an ataccess file which I did and followed their instruction but then my site would work and I ended up getting a message when trying to go to my site saying something like “too many redirrects”. Cloudflare Support says they can see that SSL is active on my www subdomin now at the moment. I’m lost…

Can you share the name of the domain here? This tutorial may assist in troubleshooting, compare the steps you’ve taken with what is specified, Step 2: Setting up SSL with Cloudflare.

1 Like