Have problems with *Read Me First*

Here are some tips for troubleshooting if you are having issues using Cloudflare’s Resolver. Please take a moment to review them along with the information that will help us to understand and help diagnose any issues. There are two sections to this guide. The first is for troubleshooting name resolution errors/issues and the second is for unreachability or routing issues.

New Diagnostic Tool We have a new diagnostic tool which can help gather some of the information requested below. If you copy the result from https://Cloudflare-dns.com/help/ to your ticket it will help immensely.

Dig Tutorial

Troubleshooting Name Resolution Issues

  1. Please search the forum to see if the domain you are reporting already has an entry (feel free to add your comments to it, if it does).
  2. Please provide the following tests from your location if possible and include it with your report.

UNIX (Linux/macOS)

dig example.com @
dig example.com @
dig example.com @
dig +short CHAOS TXT id.server @
dig +short CHAOS TXT id.server @

And if you are willing to share information about your network block, please include the output of this next command as well. Note: This does reveal your IP address, so if you aren’t comfortable sharing we understand.
dig @ns3.Cloudflare.com whoami.Cloudflare.com txt +short


nslookup example.com
nslookup example.com
nslookup example.com
nslookup -class=chaos -type=txt id.server
nslookup -class=chaos -type=txt id.server

And if you are willing to share information about your network block, please include the output of this next command as well. Note: This does reveal your IP address, so if you aren’t comfortable sharing we understand.
nslookup -type=txt whoami.Cloudflare.com ns3.Cloudflare.com

Those first two tests should show what the Cloudflare resolver provides vs. Google’s resolver and the 3rd test should report which of our nameserver locations you are connected to.

  1. If you want to go the extra mile, doing a test at http://dnsviz.net/ and posting a link to the results can often be helpful as well.
  2. Please include any additional information about the domain/ lookup that you think might be helpful or relevant.

Troubleshooting Unreachability or Routing Issues

  1. Please search the forum for your country name and ISP to see if the issue may have already been reported. If it has please review that post and add any comments you may have to it rather than creating a new post.
  2. Please provide a traceroute for both and (even if you can reach one and not the other).

UNIX (Linux/macOS)




  1. If you believe Cloudflare’s route is suboptimal, please provide a traceroute to a DNS server which you believe has better routing (we can’t always improve routing, but it’s helpful to have information/context when we communicate with ISPs and network providers).
  2. If the traceroute reaches Cloudflare please also include the output for

UNIX (Linux/macOS)

dig +short CHAOS TXT id.server @
dig +short CHAOS TXT id.server @

Bonus points if you include these 2:
dig +tcp @ id.server CH TXT
dig +tcp @ id.server CH TXT


nslookup -class=chaos -type=txt id.server
nslookup -class=chaos -type=txt id.server

Bonus points if you include these 2:
nslookup -vc -class=chaos -type=txt id.server
nslookup -vc -class=chaos -type=txt id.server

  1. For DNS over TLS issues:

UNIX (Linux/macOS)

openssl s_client -connect
openssl s_client -connect

Gold star :star: if you also include:
kdig +tls @ id.server CH TXT
kdig +tls @ id.server CH TXT


There is no standalone DoT client for Windows yet, so only the SSL connection can be checked (requires a manual installation of OpenSSL)

  1. For DNS over HTTPS (DoH) connectivity issues please also run the command below and paste the results of the file in your report as well:
  1. If your traceroute dies at the first hop, your issue is almost certainly hardware related, your router may have a hardcoded route for If that is the case, please provide the make/model of your router as well as your ISP.

  2. Please also consider opening a ticket with your ISP for unreachability or routing related problems as well. We try very hard to work with other network providers when a problem is discovered, but sometimes those providers have other priorities. Your feedback to them helps them to determine this is an issue worth investigating.

Finally… Thank you, thank you, thank you :orange_heart:
We very much appreciate that you are using Cloudflare’s public resolver and we’re sorry that you encountered an issue that requires some troubleshooting on your part. Your willingness to help us determine the cause of the issue by providing diagnostic information is appreciated.

Do ISPs block seems to be blocked or something
Certain website suddenly not reachable with cloudflare dns
Cant reach but works great still blocked from etisalat egypt adsl Not working
Cannot resovle server names
Website unavaible via DNS, but ok on other networks
Unable to connect to IPv6 Resolver
Can not reach, only
Community Tip - How Do I...Answers to Popular Questions is faster than
Cdn.jsdelivr.net fails to resolve using DNS over TLS
Unable to reach a sub site from Chamberlain.edu
DNS is unreachable cannot resolve google sites
Possible to Use with CenturyLink?
Specify AnyCast servers to use when using
DNS recursion Timeout Vulnerability Android 6.0.1
DoH connectivity issues in UK
NXDOMAIN/SERVFAIL for google.com from (Amsterdam/NL)
Serious issues to in uk
Serious slowdown in Brooklyn, NY still not working from Telecom Argentina
High ping in algeria using cloudflare dns
Cloudflare DNS make wrong IP Destination of Garena VN
Cannot resolve nbp.pl
Why the dns is faster than for me? still doesn't work on Orange France not showing correct data for bsrgroup.com.au ( and are fine)
AT&T Internet 1000 not working with
Samsungipolis.com is not found
DNS over TLS > Wrong look ups for co.uk domains
Unable to resolve Nasa domains
TLS13 not working for DNS over TLS
Not Work DNS DNS Not Working In Som Countries
Problem with in Brazil
Very important question about dns
Issues accessing & on TSD Telecom ISP
Issues accessing & on TSD Telecom ISP
Can not access to 3u.com
[LA] Is Cloudfare extremely unstable to anyone else? blocked by ISP in madagascar
IDM website
Welcome to can't resolve gigabituk.com even after purging ( Works fine from other resolvers ) - High latency from PK is unreachable in Hong Kong Telecom
Cloudflare unusable
Unable to resolve/ping
Name Resolution Issues - iFood Brazil
Cant reach but works great
DNS Request Timeouts (Error Message inside)
High Ping and
Android DNS
Singapore - Singtel 89ms
Introducing with Warp! isn't working resolving IP question
Problems with (Unreachable)
DNS cloudflare not resolved npvr-mss.cdns.cdn.orangetv.orange.es
Can't resolve an URL
Having connectivity issues today to DNS
Cloudflare's DNS servers fault
Cloudflare DNS cannot resolve my domain: DGAC.GO.CR
Help us test a new version of Public DNS resolver
Can't resolve canadacentral.cloudapp.azure.com DoH not working on Brave
How to fix DNS timeout?
Nac-cna.ca failing to resolve
Unable to resolve: vmlabblog.com
Epic Games' CDN failing to resolve; Google's DNS works
Cannot send email to specific domain
Dell.com doesn't resolve on
Cannot resolve https://www.ncbi.nlm.nih.gov suddenly stopped working as DNS for our network
DNS problem resolving
Issue with cloud dns on ispserver internet provider
Customer Support Ticket
Customer Support Ticket
HTML5 & Websocket Connections Blocked & Cloudflare
Website minvu.cl is not reached using cloudflare dns service
MSP seeing all of our Michigan Comcast customers experiencing 25 to 40% packet loss to CloudFlare DNS and
Cloudflare DNS ( in "DUS" region not reliable on Android and Ubuntu
Having issues with enabling to all my device App Slow
Turkey performance issue is timing out for me, all websites very slow
SERVFAIL for heiconf.uni-heidelberg.de and blocks screenleap.com?
Unable to access imgur.com
Help bad routeo isp to cloudflare services
CSGO matchmaking not working with WARP
Packet Loss to from multiple networks
Website resolves using google DNS, but not cloudflare?
Our domain doesn't resolve at the Cloudflare DNS
DNS Resolution failure
DNS_PROBE_FINISHED_NXDOMAIN newmexico.gov working with high latency in Argentina
SERVFAIL on newmexico.gov websites
Public DNS times out when connected to Cisco IPSec VPN on macOS
Default Server:unknown gets high ping in the Philippines
Wrong Cloudflare Datacenter
DNS Propogation for Website Outside of Cloudfare
Why can't open our school site using dns and
How to tell that some sites are not resolving?
Yahoo mail not loading
Not Opening The Website
High Packet Loss to DNS
How to get 1111 at the Router level so all connected devices have VPN privacy protection
USPS.com servfail on
SERVFAIL for securebanking.myrams.com.au
Not able to access internet issues with Frontier FiOS or Meraki
Can't Get to Work. What am I Doing Wrong?
Servers at acfr.usyd.edu.au not resolving on
Cloudflare DNS Incorrect Name Resolution lastpass.com
Cloudflare DNS Incorrect Name Resolution lastpass.com
URL will not resolve using
Can’t get DoH to work
(emergency)Not resolving a certain domain
One.one.one.one can't find www.espoo.fi: Server failed address isnt working not working, is fine
What's not working with
Community Tip - Tools and Resources
Cloudflare DNS service can't find a domain DNS not ping from my ip DNS not ping from my ip
Can't access
(External) Domain cannot be resolved by Cloudflare
Access from my AS to Cloudflare services
Domain unresolve when using
Googlevideo.com Not Resolving is slow and having issues loading sites
Dns in israel
Cannot access Taiwan News unless changing Cloudflare DNS to Google DNS
Traffic from my server takes weird path to
Unable to resolve upstate.edu with
The set DNS record cannot return to the set record value normally
Can't open website with DNS
Is it just me or is much reliable than
"parler.com" does not resolve off of CloudFlare's public DNS servers
WebEx not resolving
SERVFAIL resolving s3-1-w.amazonaws.com not reachable on Telefonica de Argentina/Movistar/Speedy ISP
Configure DNS Manually issues with Hathway (India)
CloudFlare Dns not working in India.ISP Airtel May have blocked it is not working with Hathway Broadband (Indian ISP)
Help accessing
Cloudflared DoH failed to perform an HTTPS request
Cloudfare DNS blocked with ACT ISP in India not reachable on TATA India network and high latency
Cloudflare Peerings in India can’t be reached isp tedata egypt can't reach US .mil websites unable to resolve MX of SFDC, only in Toronto area
Simple questions: CloudFlare DNS-over-TLS

Additional Info:
It was pointed out to me quite quickly by our DNS and Network gurus that the above guide lacks love for IPv6.

For any of the commands above which use or the IPv6 addresses of Cloudflare’s servers can also be used. Those addresses are:

2606:4700:4700::1111 and 2606:4700:4700::1001

How to install kdig
On macOS: brew install knot
On Linux: apt-get install knot
On freeBSD: pkg install knot