Has the Free Plan 100 seconds timeout been changed to 30 seconds?

Has the 100sec timeout been changed to 30sec? All of my servers that use CF to resolve DNS now timeout activity after 30s. If I bypass CF then I have no problem. Tried this on multiple domains on the free plan and different servers on different platforms, all with the PHP timeout for Wordpress set to more than 100 seconds. For example, when installing a plugin like WooCommerce it can take about 45 seconds. With CF on, the install fails multiple times. Bypass CF and the install happens first time after 45 seconds.

Just double checked and if I proxy the domain there is a timeout at 30 seconds on the free plan. If I disable the proxy for the domain then there is no timeout. There is no error message I can find in any log file.

That means you got Error 524 right?

No. Like I said I didn’t get any error code that I can find. The script, whatever it is, just terminates after 30 seconds instead of 100 seconds.

100 seconds timeout should have Error 524 as the result. And if the timeout duration has been changed to 30 seconds, you should get the same error too.

Since you said you were not getting an error code after 30 seconds, that means the timeout could be something else.

2 Likes

Yes. agree. I just wonder what it is. If I remove the proxy from the DNS entry then there is no time out at 30 seconds, so it has to be something at CF doesn’t it? I’ve tried this on multiple different servers.

Ticket 2249370 - @MoreHelp

I’m not aware that the timeout has been reduced, and given that you are not getting a 524, and there is no other evidence to say there is a timeout, I would be inclined to rule that out.

Can you check your Cloudflare Firewall Logs for any related events?

This post was flagged by the community and is temporarily hidden.

It’s impossible to reduce the timeout duration.

1 Like


No it’s possible

I mentioned “reduce”.

4 Likes

Nothing there.

OK. So I got creative and made a couple of PHP scripts on two different servers. On the Cloudflare proxied server I had a script that simply waited for either 20, 60 or 120 seconds and then sent a response. On the other server I had a php script that used curl to make an https request to the other server. Everything worked exactly as expected!

I went back and tried the long running update that had been failing before, and it worked also! This has been a problem for a little while now on a number of my sites, but seems to be resolved. I haven’t changed anything. Oh well. Thanks for your input everyone.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.