HaProxy - Error 525 - SSL Handshake Failed

Have a 5 web servers behind an HAproxy server with a valid SSL cert from Lets Encrypt. site works perfectly fine, when I activated clouldflare its falling apart, sometimes it works then it dies with the Error 525 - SSL Handshake Failed

tried various scenarios, all with the same outcome. also created the cloudflare SSL origin cert and installed… it appears on my web site now, as well same error with the cloud flare cert.

i’ve added every cipher possible and still the 525 error

not sure why this is so difficult.

can i not just use my own SSL cert that’s already installed on my servers, not sure why cloudflare has to get “involved”

You can edit the DNS entry for the hostname(s) in question and click on the :orange: and switch it to :grey: (DNS Only).

thank you kindly, I will try that. Will the site still be able to utilize the WAF features of the professional version once we move to that?

thanks again!

If you want WAF, then Cloudflare will have to get “involved” by proxying your site.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.