GTmetrix and 500 message caused by cloudflare - how do I fix?

Hi,

I have started using cloudflare today, and have changed my nameservers as instructed. I wanted to check the effect on my site speed but when I try and test using GTmetrix I get a 525 message. If I follow the FAQ help link, it says a common reason for this is using a reverse proxy (cloudflare). Please see screen shots below.

My website (www.greatix.org) seems to be functioning fine and I don’t get any error messages when I navigate to it using safari, chrome or firefox. I paused cloudflare for the site and then GTmetrix works again.

I searched the help forums and found a message thread with someone having a similar problem who was advised to add another A record but I’m not sure if this is also what I need to do as I already have an A record with an ip - I also don’t really understand my DNS records as I am not a techie (you prob worked that out!)…is anyone able to help me? Thanks.



image

You’re not currently using Cloudflare as a proxy, it’s just serving the DNS record. My first attempt at a curl to the origin resulted in an SSL error, subsequent requests worked. First failure could be similar to what GTMetrix saw on it’s first attempt to connect…

curl -Iv https://www.greatix.org
*   Trying originIP:443...
* TCP_NODELAY set
* Connected to www.greatix.org (originIP) port 443 (#0)
* ALPN, offering h2
* ALPN, offering http/1.1
* successfully set certificate verify locations:
*   CAfile: /etc/ssl/certs/ca-certificates.crt
  CApath: none
* TLSv1.3 (OUT), TLS handshake, Client hello (1):
* OpenSSL SSL_connect: SSL_ERROR_SYSCALL in connection to www.greatix.org:443
* Closing connection 0
curl: (35) OpenSSL SSL_connect: SSL_ERROR_SYSCALL in connection to www.greatix.org:443

Thanks for the super speedy reply, but I’m going to need patronising as I don’t understand what a curl is or what that means for my problem and how I can address it.

I had cloudflare paused for the site when you ran your curl, but I have now re-activated it. Would that make any difference?

The problem is def something to do with cloudflare as I consistently get the problem when I activate it, and it goes away if I pause it for my website. I’m a real beginner in the website world, sorry if these seem like very stupid questions :grimacing:

It would. I get a 525 error as well when hitting the site through Cloudflare. Check this article for troubleshooting steps on 525 errors.

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.