Green pad lock error on webpages

ssl

#1

Hello. I have integrated ssl flexible through cloudflare.Green padlock is displaying only on the homepage but not on all the other webpages… Its displaying just for an instance and disappearing after the page loads fully. Please fix this problem.

https://www.duacentre.com/hajat-desire-wish-fulfilment-wazifa/
https://www.duacentre.com/category/love-marriage-zone/marriage/


Always use HTTPS doesn't always work
#2

That’s something you’ll have to fix on your site. It’s a Mixed Content error:

There’s also this asset which is having SSL trouble:
https://www.momamoclub.com/banner/backlink80x15_a1.gif


#3

Hi there.

http://duacentre.com/wp-content/uploads/2017/05/fnbg.png is holding you up on both pages you linked. I see you’re using Wordpress, you can probably fix this in wp-admin and/or re-upload the image.

Edit: apologies I did not see that somewhat tiny image @sdayman already provided regarding this.


#4

Hello.

I have fixed these issues and I have also enabled always rewrite https but still the same problem in webpages.

https://www.momamoclub.com/banner/backlink80x15_a1.gif

http://duacentre.com/wp-content/uploads/2017/05/fnbg.png


#5

Here is what I see when I analyze the fnbg.png asset.

Note the request URL at the top is http:// despite the asset being located at https://


#6

I have already changed it to https in source code. Please see the attachment. If something else has to be done to fix it then pls tell the method of how to fix it.!


#7

Hello again. I am seeing :lock: at this time! Your change appears to have resolved the issue. You may need to clear your browser cache and/or view the page in a private tab to verify. I can also confirm that this image is being served via Cloudflare cache:
cf-cache-status: HIT


#8

I cleared cache and tried. Still no green symbol is to be seen. Do I need to make any changes in cloudflare account settings. If so what changes???

Thank you


#9

No, you shouldn’t need to. I’ve tested with various browsers from different locales, including iOS Safari via LTE connection and get a lock in every instance. Have you checked using another machine and/or phone?


#10

Which url have you checked? Its fine with homepage, contact, courses, and paypal page. Other then these pages its not displaying .

I have tried from different device as well.


#11

I have been checking the URLs that you provided in your initial post. I’m using Firefox developer tools network tab to view all asset loads and checking the headers. Using developer tools typically disables all local cache function to force request from the origin. There is a setting for this under the :gear: icon “Disable HTTP Cache”. I also utilized a similar method with Chrome.