Government Web Site is not Resolved

Hi,

  1.1.1.1 seems to work great for 99.9999% of sites:

este:~> host www.google.com
www.google.com has address 172.217.5.68
www.google.com has IPv6 address 2607:f8b0:4007:802::2004

However, it does not work for this government web sites someone at my company needs access to:

este:~> host predict.cdc.gov
Host predict.cdc.gov not found: 2(SERVFAIL)

Yet, on this machine which is using  different resolvers

PLEIADES> host predict.cdc.gov
predict.cdc.gov is an alias for predict.glb.cdc.gov.
predict.glb.cdc.gov has address 198.246.102.73


Any clue? Thanks!

There is no issue with 1.1.1.1,

host predict.cdc.gov 1.1.1.1

Using domain server:
Name: 1.1.1.1
Address: 1.1.1.1#53
Aliases:
predict.cdc.gov is an alias for predict.glb.cdc.gov.
predict.glb.cdc.gov has address 198.246.102.73

dig predict.cdc.gov @1.1.1.1

; <<>> DiG 9.10.6 <<>> predict.cdc.gov @1.1.1.1
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 65529
;; flags: qr rd ra ad; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 1
;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 1452
;; QUESTION SECTION:
;predict.cdc.gov. IN A
;; ANSWER SECTION:
predict.cdc.gov. 3472 IN CNAME predict.glb.cdc.gov.
;; AUTHORITY SECTION:
glb.cdc.gov. 3472 IN SOA ns1.glb.cdc.gov. hostmaster.ns1.glb.cdc.gov. 2019083003 10800 3600 604800 86400
;; Query time: 43 msec
;; SERVER: 1.1.1.1#53(1.1.1.1)
;; WHEN: Sun Sep 01 11:51:21 EEST 2019
;; MSG SIZE rcvd: 125

Four months later there might not be any longer :wink:

1 Like

I joined community too late :sweat_smile: