Not Resolving

ISP: Google Fiber
Primary DNS:

Having issues with using Cloudflare DNS on wifi devices to access YouTube/YouTube TV video streams? If I switch to Google DNS ( everything works again. Also desktop wired computers work fine on both.

Not sure if Google Fiber is blocking
But you can try these: and

No dice after trying to clear DNS cache. I’ve also tried Quad9 DNS and it works too.


What’s the complete link from the test? If the forum won’t let you post a link, take some of the dots out of the hostname.


That’s certainly weird, if everything is stuck on Checking…

More instructions here, notably the section on Unreachability or Routing Issues:

Hi! I am having the same issue for the last few days. YouTube loads with Google DNS but not with Cloudfare. I also see people tweeting about the same. What is causing the issue all of a sudden?

conr, which browser are you using and version?

I too am seeing this issue. Happens trying to view YouTube videos on safari and with the native app. Switching from Cloudflare dns to google dns fixes the problem.

There’s a reddit thread with others having the same issue - site not letting me post link :(.


1 Like

I’m seeing roughly the same as others. I was using and and in the last few days YouTube as effectively stopped working on my home network. I can get to the site and browse videos (from desktop computer or iOS device). However, it’s when you go to play a video that it just sits there and the video never loads.

I started ruling out things in my environment and determined that if I swapped out the Clourflare DNS servers for Google ( that YouTube went back to working properly. It seems like others are having a similar experience.

I don’t have a resolution but wanted to share my experience here in hopes that Cloudflare can look into this issue further.

Having the same issue here. I first noticed it about 1pm (Central) on Wednesday July 27 when it failed to work. It worked that morning, but beyond that, no luck. I can’t use YouTube on any device on my network or YouTube TV, had to switch to Quad9 and it worked. It works on any an all other DNS providers besides Cloudflare. So something is up and they will need to look into it.

I’m not clear on what the issue is, because resolves for me at Cloudflare DNS:

% dig +short @

 % dig +short @

Go through both of those enough times, and you’ll see recurring patterns, and the occasional match:

% dig +short @

% dig +short @

If you think you’re having DNS issues, please follow the instructions I linked to earlier:

I’ve narrowed down the issue. There are topics all over the place, but the gist of it is this. Every video load creates a new CNAME

Jul 31 03:06:52 dnsmasq[3440]: query[A] rr3—sn-qxoedn7z.googl evi eo.c .c om to
Jul 31 03:06:52 dnsmasq[3440]: forwarded rr3—sn-qxoedn7z. googlevideo . com to
Jul 31 03:06:52 dnsmasq[3440]: query[A] rr3—sn-qxoedn7z. googlevideo. com from
Jul 31 03:06:52 dnsmasq[3440]: forwarded rr3—sn-qxoedn7z. googlevideo. com to
Jul 31 03:06:52 dnsmasq[3440]: reply error is SERVFAIL

This is a log from my pihole. Same video hit the refresh button and it’s a different CNAME.

Either google is purposely slowing down resolution to other DNS’s or something.

Also if you manually run that CNAME a second time, then CF will return a A record. It’s always the first lookup that’s returning SERVFAIL.

Frankly it appears google might be abusing CNAMES as a tracking mechanism.

1 Like

Thanks for sharing this. I can confirm and am seeing this also.

How do we get CF’s attention to this though. I think maybe they can double tap these domains before responding, or at minimum have the pull to get ahold of the right person at google.

He copied the link wrong, it’s:

That’s not the issue it’s google changing CNAME’s every time you try to load media. The CNAME changes even for the same item. I think they’re trying to backdoor tracking, but at the same time ns2. google .com appears to be failing lookups according to dnssy. So even the browser app retrying will just get a new CNAME and Cloudflare will return a SERVFAIL the first time that gets hit. This is happening across the board with a lot of ISP’s with people using non google DNS servers.

Anyone know if this issue was resolved?

This seems to have resolved itself.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.