Googlebot is blocked due to country rule

We had added a WAF rule to block all countries except Australia as we were receiving some fraudulent transactions on our website from USA.

However, we noticed that the whole bunch of products started to be disapproved. We could see that the google bot IPs were still getting blocked due to the country rule.

We also disabled the mode of the chosen rules under 100035, however when we go to Google search console for analysing pages, Googlebot is being presented with a 403 error.

Could you please let us know a fix for this as we want to block USA traffic, but at the same time ensure that the good bots are doing their job.

I can see this problem has been faced by many and cloudflare implemented a fix, but it’s not working in our case: https://www.cloudflarestatus.com/incidents/pld51xj2hlpy?_ga=2.215007895.1801758062.1607901706-1750525643.1583366303

What WAF rule did you add? It sounds more like a network Firewall setting.

100035 is Fake Googlebot, so this rule doesn’t apply.

If I were to block all but one country, I’d use a Firewall Rule so If NOT (my country), and NOT Known Bots, then Block.

Thanks sdayman. I had only added this rule:

image

image

Have now revised it to what you have mentioned above. Hopefully this works. Our SEO guy has said that as the data doesn’t update instantly, we will have to wait until tomorrow morning to see the results.
So the above rule that you have stated will block only if not known bots correct? That means, there should be no disapproved products.

Hi Guys,

We added the below firewall rule and our google shopping feed was working fine for few days. However since last week, our shopping feed is completely offline. We are getting an error - ‘Authentication failed’.
Does anyone know the solution to this?

This topic was automatically closed after 30 days. New replies are no longer allowed.