Google Workspace redirect not working

We used to be able to type mail.tap5050.com in our browser and be redirected to our gmail account but now we get a 525 SSL error page. This happens on Edge, Firefox, and Chrome.

Talking to Google Workspace support they said:

“I can highly suggest if you want to use still please contact Cloudflare and ask them to fixed it so that 2 dimensions can collide.”

Anyone have any idea how to accomplish this change. As of right now I am using basic Cloudflare package and do not have access to support.

Welcome to the Cloudflare Community. :logodrop:

Have you read the automatically linked Community Tip article in your post?

2 Likes

According to Google:

You can tell that you have set up a Custom URL in Google Workspace by adding a CNAME (ghs.googlehosted.com) for the Sub domain (Mail) . However, there is an error saying “SSL handshake failed” when we searched with (mail.tap5050.com) . This should be redirected via HTTP (as Google only supports HTTP connection). But as a new update in Cloudflare it is being redirected via HTTPS .

I am not sure how I would do this.

I don’t have a solution for you, but I can confirm that the redirectm to ghs.googlehosted.com is failing using HTTPS. I had some aliases pointed to that Google canonical name that now fail if I specify the HTTPS scheme. If I just type in the hostname it works. My records do not happen to be in any of my Cloudflare DNS zones.

One thing that may help is changing your CNAME from :orange: to :grey:. Right now when I look up your mail.tap5050.com hostname, I see A records instead of a CNAME. This is caused by having the Cloudflare proxy :orange: enabled. If you set that record to :grey: DNS Only, Cloudflare will return a CNAME. This may help. If it does not work in a regular session after making that change, test again it an incognito browser session to rule out any browser cached settings.

2 Likes