Google workspace broke my email

Figured I would try out gmail for my business but I wasn’t getting 80% of my email due to most coming from webforms. No one could seem to figure it out so now just want to go back to normal since I’m a week behind on lost email/customers. Now even that doesn’t work (local computer using Thunderbird). They tell me the issue is on Cloudflare due to validation but can’t seem to figure out what I need to do.

Greetings,

Thank you for asking.

I am sorry to hear you are experiencing an issue with receiving and/or sending e-mails from your Website while using Coudflare for your domain name.

If you followed Google’s page on how to setup Google Workspace and Cloudflare, your DNS records should look like something from below screenshot (as an example):

May I ask could you share your domain name here with us and a screenshot of your DNS records from the Cloudflare dashboard? :thinking:
If so, please consider masking (hiding) the data on the screenshot like the server/hosting IPs and similar due to public posting.

May I ask how did you configured your application/script/web form to use the function to send emails, which SMTP server and other authorization to send you an e-mail?
Or was it a web form on some Website, meaning the web server (behind proxied :orange: hostname of the domain) was sending the e-mail not being authenticated to send e-mails, instead of your Google Workspace SMTP? :thinking:
Are you using some kind of a CMS like WordPress, or a plugin maybe? :thinking:

Might be youre sending and/or receiving hostname (server) is configured to a proxied :orange: hostname, instead pointed to an unproxied :grey: (DNS-only).
But, if you are using Google Workspace, you might be using aspmx from Google, so not sure what’s wrongly configured without more feedback information from you.

Usually, the MX record should point to a hostname such as mail , and the A (or CNAME ) type record for that hostname should be set to :grey: (DNS Only).

Furthermore, if you recently moved your domain to your Cloudflare account, I could try to troubleshoot at first sight without knowing anything other as it could be related to either:

  1. Wrongly setup e-mail related DNS records at the DNS tab of Cloudflare dashboard for your domain name
  2. Possibly missing some TXT/CNAME records (for SPF, DKIM, DMARC if so?)
  3. You are using a hostname like yourdomain.com which is :orange: (proxied) rather than the unproxied :grey: (DNS-only) like mail.yourdomain.com (possible this one not existing or is :orange: instead of being :grey:) at the DNS tab of Cloudflare dashboard, in your e-mail client for sending/receiving server (MS Outlook, Mozilla Thunderbird, etc.)

May I suggest checking below article if your e-mail records (usually the A mail and the MX record) are configured properly while you are using Cloudflare for your domain name:

1 Like

Originally, yes, it did look like that. But since I have had nothing but trouble with gmail I just want to get things back to normal. I ended up simply adding an MX record for mail.mysite.com to bypass the issue Cloudflare was giving me and all currently seems back to “normal” without the use of Gmail. Not sure why the CF settings were causing so many problems as I though I could just revert back but it appears that was not the case even when using CF’s recommended MX records.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.