Google Sites says "Invalid DNS"

I have a Google Sites website. I want to link a domain I have registered on Cloudflare to the site. It’s probably a simple error but it isn’t working and Google Sites says “DNS Error” with the domain. Is there a record I need to add or change in my DNS settings?

Change the CNAME from “Proxied” to “DNS only”.

Although not relevant as you then won’t have any proxied records, you should also set your SSL/TLS settings to “Full (strict)” in case you add other records in the future, here…
https://dash.cloudflare.com/?to=/:account/:zone/ssl-tls

You may also want to redirect doorcityband.com to www.doorcityband.com which can be done on Cloudflare.

3 Likes


Thanks! Should the redirect rule look like this?

Also, I’m still getting this message in my DNS settings. Should I do anything about this? Thanks for your reccomednations.

For a redirect, make sure you add a DNS entry for what you are redirecting from. Add a proxied record for @ as A 192.0.2.1 or AAAA 100:: as dummy records as there is no real site.

For a Page rules redirect I would use:
Redirect from *doorcityband.com/*
to https://www.doorcityband.com/$2

But better to use a redirect rule as page rules will be phased out later.
https://dash.cloudflare.com/?to=/:account/:zone/rules/redirect-rules

Copy this example, just change the hostnames…

(remove the page rule if you go this way).

2 Likes

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.