Google site with custom domain NET::ERR_CERT_DATE_INVALID

Answer these questions to help the Community help you with Security questions.

What is the domain name?
stillcosangha.ca
points to https://sites.google.com/view/stillcosangha/home

Have you searched for an answer?
I have searched multiple days in a row

Please share your search results url:
I keep trying to post this but I get errors because I can’t post links.

SSL LABS

When you tested your domain, what were the results?

This certificate is expired GTS CA 1D4
I found this certificate, I downloaded it but I don’t know what else to do. Steegle says google sites have automatic SSL so I think I might have a cloudflare setting wrong.

Describe the issue you are having:
This has been set up for 9 months, just stopped working last week, despite the certificate error saying it expired in October. After I updated my email address with google and cloudflare I got a 525 error. Resolved that and now am stuck with an expired SSL issue. I have tried the cloudflare fixes I could, but the “origin server” direction confuse me in application with a google site and I sense it must be the wrong resolution approach.

when I use the custom domain it is not secure and I have tried to fix it with my domain registrar (That was the barking up the wrong tree)
with Cloudflare - following this guide to check what I might have been missing [STEEGLE](https:// www.steegle. com/google-sites/how-to/assign-custom-url-domain-personal)

What error message or number are you receiving?
certificate error`

What steps have you taken to resolve the issue?

  1. used cloudflare community posts and followed as far as I could, multiple times
    1b. paused cloudflare, tried to troubleshoot, restarted cloudflare and tried different ssl settings.
  2. posted the issue with google community and waiting for response, in addition to following multiple posts on how to set up google site. I have owner verification.
  3. ensured the issue couldn’t be resolved through my domain registrar
  4. ran it through ssl checker and a couple others and tried to understand the information and follow what I could to fix it.

Was the site working with SSL prior to adding it to Cloudflare?
It was working with cloudflare up to last week

What are the steps to reproduce the error:

  1. enter the custom domain with or without www into a browser

Have you tried from another browser and/or incognito mode?
repeatedly, both

Please attach a screenshot of the error:
posted above

Posting process notes: Can’t post links. I tried the hyperlink option above and it doesn’t solve the error. Why does it ask me to post a link and then say don’t post links? This is so confusing. Which is the “preformatted text” option? None of the preformatted options have that as a description. I am just adding apostrophes to everything now. Okay, I learned what a backtick is, hopefully this works.

completed the new user tutorial, hoping the image will post now:

The SSL Labs test result:
https://www.ssllabs.com/ssltest/analyze.html?d=stillcosangha.ca

Update: I hadn’t removed and re-added the domain on the google site - I have done that now.
now I am getting ERR_CONNECTION_CLOSED

I have tried different SSL settings and flushed the DNS cache (things I read to try).

I will update if this changes, but otherwise still welcoming help.

Fixed!! All just started working.

Okay, now I would just love help with the SSL and which setting is best.
I am concerned that if not Full Strict it is not secure.
Sometimes I worry that is responsible for issues with accessing the site.

Thanks

Is there some way I can add the origin server stuff to the google site somewhere and make it work?

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.